多校训练赛1:C. Triangle Partition(按关键词排序?不知道)

Chiaki has 3n3n points p1,p2,…,p3n It is guaranteed that no three points are collinear. 
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points. 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case: 
The first line contains an integer n (1≤n≤10001≤n≤1000) -- the number of triangle to construct. 
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109−109≤xi,yi≤109). 
It is guaranteed that the sum of all nn does not exceed 10000. 

Output

For each test case, output nn lines contain three integers ai,bi,ciai,bi,ci (1≤ai,bi,ci≤3n1≤ai,bi,ci≤3n) each denoting the indices of points the ii-th triangle use. If there are multiple solutions, you can output any of them. 

Sample Input

1
1
1 2
2 3
3 5

Sample Output

1 2 3

 

【解析】

这估计是最简单的一题了吧。。。。。

文中有句话说任意三点不共线,那么就很简单了,按照每个点的x,y排个序,然后依次编号输出就行了。

 

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
struct point
{
	ll x, y;
	ll d;
}po[3010];
bool cmp(point a, point b)
{
	if (a.x == b.x)
		return a.y < b.y;
	else
		return a.x < b.x;
}
int main()
{
	ll t;
	scanf("%lld", &t);
	while (t--)
	{
		int n;
		scanf("%d", &n);
		for (int i = 0; i < 3 * n; i++)
		{
			scanf("%lld%lld", &po[i].x, &po[i].y);
			po[i].d = i + 1;
		}
		sort(po, po + 3 * n, cmp);
		for (int i = 0; i < n; i++)
			printf("%lld %lld %lld\n", po[3 * i].d, po[3 * i + 1].d, po[3 * i + 2].d);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值