ZCMU-2959:Amity Assessment

2959:Amity Assessment

Time Limit: 2 Sec  Memory Limit: 256 MB
Submit: 55  Solved: 19
[Submit][Status][Web Board]

Description

Bessie the cow and her best friend Elsie each received a sliding puzzle on Pi Day. Their puzzles consist of a 2×2 grid and three tiles labeled 'A', 'B', and 'C'. The three tiles sit on top of the grid, leaving one grid cell empty. To make a move, Bessie or Elsie can slide a tile adjacent to the empty cell into the empty cell as shown below:

In order to determine if they are truly Best Friends For Life (BFFLs), Bessie and Elsie would like to know if there exists a sequence of moves that takes their puzzles to the same configuration (moves can be performed in both puzzles). Two puzzles are considered to be in the same configuration if each tile is on top of the same grid cell in both puzzles. Since the tiles are labeled with letters, rotations and reflections are not allowed.

 

Input

 The first two lines of the input consist of a 2×2 grid describing the initial configuration of Bessie's puzzle. The next two lines contain a 2×2 grid describing the initial configuration of Elsie's puzzle. The positions of the tiles are labeled 'A', 'B', and 'C', while the empty cell is labeled 'X'. It's guaranteed that both puzzles contain exactly one tile with each letter and exactly one empty position.

Output

 Output "YES"(without quotes) if the puzzles can reach the same configuration (and Bessie and Elsie are truly BFFLs). Otherwise, print "NO" (without quotes).

Sample Input

AB

XC

XB

AC

Sample Output

YES

HINT

 

The solution to the sample is described by the image. All Bessie needs to do is slide her 'A' tile down.

 

【解析】

题意:给你张2*2的表格,X表示空,问是否能从第一张图变化到第二张图。

因为是2*2的表格,所以只有两种转法,要么顺时针一直转,要么逆时针一直转。所以我们可以先处理成两个字段,都按顺时针方向分别处理成ABC和BCA。   我们只要一个转,另一个固定就好。模拟一下就是把第一个字段加长成一样的ABCABC。然后在这个字段中寻找BCA就好。

#include <bits/stdc++.h>
using namespace std;
int main()
{
	string a, b, c, d;
	while (cin >> a)
	{
		string s1, s2;
		cin >> b >> c >> d;
		for (int i = 0; i < 2; i++)
			if (a[i] != 'X')
				s1 += a[i];
		for (int i = 1; i >= 0; i--)
			if (b[i] != 'X')
				s1 += b[i];
		s1 += s1;
		for (int i = 0; i < 2; i++)
			if (c[i] != 'X')
				s2 += c[i];
		for (int i = 1; i >= 0; i--)
			if (d[i] != 'X')
				s2 += d[i];
		if (s1.find(s2) == string::npos)
			puts("NO");
		else
			puts("YES");
	}

	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值