dp01背包——A - Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 




Input
The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output

14

这道题是典型的01背包问题,即dp问题,给出物品数量和背包总体积,再给出每个物品的体积和其价值,f[v]=max(f[v],f[v-c[i]]+w[i]);这是dp问题的主要解题模板,其演示效果如下图:


每次都找最优解,最后的解一定是最优解。

代码如下:

#include<stdio.h>
#include<string.h>


int max(int x,int y)
{
if(x>y)
return x;
else
return y;
}
int main()
{
int i,j,c[1010],w[1010],f[1010],n,m,v,z,t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
memset(f,0,sizeof(f));
memset(c,0,sizeof(c));
memset(w,0,sizeof(w));
for(i=1;i<=n;i++)
{
scanf("%d",&w[i]);//价值 
}
z=0;
for(i=1;i<=n;i++)
scanf("%d",&c[i]); //体积

for(i=1;i<=n;i++)
for(v=m;v>=c[i];v--)
f[v]=max(f[v],f[v-c[i]]+w[i]);

printf("%d\n",f[m]);

return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值