Bone Collector

Bone Collector
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Example Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Example Output

14

Hint
hdoj2602 http://blog.csdn.net/u014231159/article/details/25605411?utm_source=tuicool&utm_medium=referral
Author

think:
这又是一道英文题,其实自己不太喜欢做英文题,因为有的地方读不懂的感觉实在是不好受,但我们都需要挑战自己,为将来打下基础。
回归题目,这是一道背包问题,大意就是给出了几组测试例子,然后又给出了骨头的数量和骨收集器的体积,然后接着是两行,第一行包含每个骨头的价值,第二行包含每个骨头的体积,要求计算出骨收集器的最大总价值。
代码实现:

 #include<stdio.h>
int max(int a, int b)
{
   if(a>b)
   return a;
   else
   return b;
}
int main()
{
    int x, n;
    int p[100005], m[100050];
    int sum[200000];
    int t;
    scanf("%d", &t);
    while(t--)
    {
    scanf("%d %d", &n, &x);
       int i, j;
       memset(sum, 0, sizeof(sum));
       for(i=0;i<n;i++)
       {
         scanf("%d", &m[i]);
       }
         for(i=0;i<n;i++)
       {
         scanf("%d", &p[i]);
       }
       for(i=0;i<n;i++)
       {
         for(j=x;j>=0;j--)
         {
            if(j>=p[i])
            sum[j] = max(sum[j-p[i]]+m[i], sum[j]);
         }
       }
     printf("%d\n", sum[x]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值