poj1852

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 21449 Accepted: 8793
Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output

4 8
38 207
Source

Waterloo local 2004.09.19
[Submit] [Go Back] [Status] [Discuss]
题意概括:
有n只蚂蚁在木棍上爬行,每只蚂蚁的速度都是每秒1单位长度,现在给你所有蚂蚁初始的位置(蚂蚁运动方向未定),蚂蚁相遇会掉头反向运动,让你求出所有蚂蚁都·掉下木棍的最短时间和最长时间。
解题思路:
因为蚂蚁都是一样的,所以当两只蚂蚁相遇时转向跟没转向没什么区别,因为每只蚂蚁都会继承另一只蚂蚁的方向,所以·可以视为蚂蚁方向不变,所以最短时间就是所有蚂蚁距端点最近距离的最大值,最长时间就是所有蚂蚁距端点最远距离的最大值。
代码:

#include<stdio.h>
#include<string.h>
#define maxn 1000050
int dis[maxn];
int min(int x,int y);
int max(int x,int y);
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int l,n;
        scanf("%d%d",&l,&n);
        for(int i=0;i<n;i++)
        scanf("%d",&dis[i]);
        int mi=0,ma=0;
        for(int i=0;i<n;i++){
            mi=max(mi,min(dis[i],l-dis[i]));
            ma=max(ma,max(dis[i],l-dis[i])); 
        }
        printf("%d %d\n",mi,ma);
    }
    return 0;
}
int max(int x,int y)
{
    if(x>y)return x;
    return y;
}
int min(int x,int y)
{
    if(x>y)return y;
    return x;
}

错误解析:
很多人可能看到题的第一印象是搜索,但是这么大数据量,搜索肯定要超时的。

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值