HDU 5166 Missing number

HDU 5166 Missing number

Problem Description
There is a permutation without two numbers in it, and now you know what numbers the permutation has. Please find the two numbers it lose.

Input
There is a number T shows there are T test cases below. (T≤10)
For each test case , the first line contains a integers n , which means the number of numbers the permutation has. In following a line , there are n distinct postive integers.(1≤n≤1,000)

Output
For each case output two numbers , small number first.

Sample Input
2
3
3 4 5
1
1

Sample Output
1 2
2 3

实现代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int Max=1010;
int num[Max];
int main()
{
    int T;
    int num_result[2];

    scanf("%d",&T);
    while(T--)
    {
        memset(num,0,sizeof(num));      //用0初始化数组num
        int n,test;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&test);
            num[test]=true;                   //下标标记输入的数字
        }
        int j=0;

        for(int i=1;i<=n+2;i++)
        {
            if(num[i]==0)
                num_result[j++]=i;
        }
        printf("%d %d",num_result[0],num_result[1]);
        cout<<"\n";
    }
    return 0;
}

memset函数作用
memset(num,0,sizeof(num)) 使数组num都初始化为0;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值