POJ 3903 Stock Exchange(LIS)

5 篇文章 0 订阅

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,…,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < … < pik, with i1 < i2 < … < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend.
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6
5 2 1 4 5 3
3
1 1 1
4
4 3 2 1

Sample Output

3
1
1

Hint


There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.

题意:

求最长升序子序列的长度,状态转移方程:d(i) = max{1, d(j)+1},其中j<i,A[j]<=A[i]

代码实现

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int L = 100000;
int seq[L];

/*
int lis(int A[],int m){  //由于每一次都要与之前的所有i做比较,时间为1s,时间复杂度n^2一定会超时
    int *d = new int[m];
    int len = 1;
    for(int i=0; i<m; ++i){
        d[i] = 1;
        for(int j=0; j<i; ++j)

            if(A[j]<=A[i] && d[j]+1>d[i])
                d[i] = d[j] + 1;

            if(d[i]>len)
                len = d[i];
    }
    delete[] d;
    return len;
}

*/
int BinarySearch(int *array, int value, int nLength)  //利用二分查找减少遍历的次数,使时间复杂度减少为nlogn
{
     int begin = 0;
     int end = nLength - 1;
     while(begin <= end)
     {
        int mid = begin + (end - begin) / 2;
         if(array[mid] == value)
            return mid;
         else if(array[mid] > value)
             end = mid - 1;
         else
            begin = mid + 1;
     }
     return begin;
}

int lis(int A[],int m) //时间复杂度nlogn
{
    int B[m];
    int nLISLen = 1;
    B[0] = A[0];

    for(int i = 1; i < m; i++)
    {
        if(A[i] > B[nLISLen - 1])
        {
            B[nLISLen] = A[i];//数组B记录最长序列的最大值
            nLISLen++;
        }
        else
        {
            int pos = BinarySearch(B, A[i], nLISLen);
            B[pos] = A[i];
        }
    }

    return nLISLen;
}
int main()
{
    int n;

    while(scanf("%d", &n) == 1 && n)
    {
        for(int i = 0; i < n; i++)
        {
            scanf("%d", &seq[i]);
        }

        int ans;
        ans = lis(seq, n);
        printf("%d\n", ans);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值