POJ2299 Ultra-QuickSort

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 9 1 0 5 4 ,
Ultra-QuickSort produces the output 0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

题解

给出一个长度为n的数列,你每一次可以随意交换其中两个数字的位置。问你至少交换几次,才能使得这个数列是个单调递增数列。
归并排序求数组中的逆序对

实现代码

#include <cstdio>
#include <iostream>
using namespace std;
#define MAXN 500005
int a[MAXN];
int b[MAXN];
long long sum;//long long 才符合题意
void Merge(int left,int mid,int right) //合并算法
{
     int i=left,j=mid+1,t=0;
     while(i<=mid && j<=right)//拷贝数组内符合循环条件的元素
     {
          if(a[i]>a[j])
          {
               b[t++]=a[j++];
               sum+=mid-i+1;
          }
          else
          {
               b[t++]=a[i++];
          }
     }
     while(i<=mid)
          b[t++]=a[i++];
     while(j<=right)
          b[t++]=a[j++];
     for(int i=0;i<t;i++)
     {
          a[left+i]=b[i];
     }
}
void Mergesort(int left,int right)
{
    if(left<right)
    {
         int mid=(left+right)/2;//求中间值
         Mergesort(left,mid);//前半部分排序
         Mergesort(mid+1,right);//后半部分排序
         Merge(left,mid,right);//递归调用
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)==1&&n!=0)
    {
         sum=0;
         for(int i=0;i<n;i++)
         {
              scanf("%d",&a[i]);//
         }
         Mergesort(0,n-1);
         printf("%lld\n",sum);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值