暑假训练 Play on Words (UVA - 10129) 欧拉回路

题目描述:
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ‘acm’ can be followed by the word ‘motorola’. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number N that indicates the number of plates (1 ≤ N ≤ 100000). Then exactly N lines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. If there exists such an ordering of plates, your program should print the sentence ‘Ordering is possible.’ Otherwise, output the sentence ‘The door cannot be opened.’
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.

代码如下:

#include<cstdio>
#include<string.h>
#include<string>
#include<iostream>

using namespace std;
int in[26];
int out[26];
int graph[26][26];
int vis[26];

void dfs(int a)
{
    for(int i = 0; i < 26; i++)
    {
        if(!vis[i] && (graph[a][i] || graph[i][a]))
        {
            vis[i] = 1;
            dfs(i);
        }
    }
}

bool euler()
{
    int cnt = 0, a = 0, b = 0;
    for(int i = 0; i < 26; i++)
    {
        if((in[i] || out[i]) && !vis[i])
        {
            vis[i] = 1;
            dfs(i);
            cnt++;
        }
    }
    if(cnt != 1)return false;
    for(int i = 0; i < 26; i++)
    {
        if(in[i] == out[i])continue;
        b++;
        if(b > 2)return false;
        if(in[i] - out[i] == 1){a++;continue;}
        else if(out[i] - in[i] == 1){a += 2;continue;}
        return false;
    }
    if(a != 3 && a != 0)return false;
    else return true;
}

int main()
{
    int t, n;
    string a;
    scanf("%d", &t);
    while(t--)
    {
        memset(in, 0, sizeof in);
        memset(out, 0, sizeof out);
        memset(graph, 0, sizeof graph);
        memset(vis, 0, sizeof vis);
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
        {
            cin>>a;
            int a1 = a[0] - 'a';
            int a2 = a[a.size()-1] - 'a';
            in[a1]++;
            out[a2]++;
            graph[a1][a2] = 1;
        }
        if(!euler())printf("The door cannot be opened.\n");
        else printf("Ordering is possible.\n");
    }
    return 0;
}

离散数学学过欧拉回路后,第一次真正使用。。。
欧拉回路的判断标准:入读等于出度,或仅有两点入读不等于出度,且这两点其一入度比出度大一,另一点出度比入读大一。还有就是要判断所有点都在欧拉回路中。。。
感觉判断的方法都很巧妙,真的学到了…………

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值