问题 D: Repair the Wall

题目描述

 

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is 
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?

输入

The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).

输出

For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.

样例输入

2 2
12 11 
14 3
27 11 4 
109 5
38 15 6 21 32 
5 3
1 1 1

样例输出

1
1
5
impossible

思路

贪心算法,

将木块的长度按照从大到小排序,然后每次取一根木块,如果取得所有的木块的总长度超过或者墙缝的长度,那么输出取出的木块的数量即为答案。如果取出了所有的木块后,总的长度仍然小于墙缝的长度,那么输出“impossible”。 

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int L, N;
    while(cin >> L >> N)
    {
       vector<int>num(N);
       for(int i=0; i<N; ++i)
       {
           cin >> num[i];
       }
       sort(num.begin(), num.end());
       reverse(num.begin(), num.end()); //从大到小
       int sum = 0, temp=0;
       for(int i=0; i<num.size(); ++i)
       {
           if(temp+num[i] >= L)
           {
               sum++;
               temp += num[i];
               break;
           }
           else
           {
               temp += num[i];
               sum++;
           }

       }
       if(temp < L)
            cout <<"impossible"<<endl;
       else
            cout << sum << endl;

    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值