Hdoj 2124 Repair the Wall 、贪心+尺取:【题解】

Problem Description

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty’s walls were made of wood.
One day, Kitty found that there was a crack in the wall. The shape of the crack is a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?

Input

The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).

Output

For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print “impossible” instead.

Sample Input

5 3
3 2 1
5 2
2 1

Sample Output

2
impossible

在昨天晚上有了思路之后,今天早上一坐到实验室用了二十分钟左右就AC了这道题。题目意思是总共有L长度的裂缝,你有N块长度不同的砖块(宽度都为1),问如何使用最少的砖块填补上裂缝。
解题思路:此题求解最少使用的木块数,可切割,所以用sort先从大到小排序,贪心思想:每次都取最大的,再套用尺取模板。我第一次wrong是因为没有从大到小排序,忘记了题目要求是选最少的砖块,而且有锯子。哈哈哈

AC代码如下:

#include <iostream>
#include <algorithm>
using namespace std;
#define LL long long
#define INF 0x3f3f3f3f
//解题思路:此题求解最少使用的木块数,可切割,先从大到小排序,贪心思想:每次都取最大的。
bool cmp(LL a, LL b){
	return a > b;
}
int main(){
	int L, N, i;
	LL a[605];						//S = L;
	LL sum = 0;
	while(scanf("%d %d", &L, &N) != EOF){
		for(i=0;i<N;i++){
			scanf("%I64d",a+i);
			sum += a[i];
		}    
		if(sum < L){
			printf("impossible\n");
			return 0;
		}					/*这一部分可以没有,加上是为了在特殊情况下节约时间*/
		sort(a,a+N,cmp);
		int l = 0, r = 0;
		int sum = 0;
		int minn = INF;
		while(r <= N-1){
			sum += a[r];
			r++;
			while(sum >= L){
				minn = min(minn, r-l);
				sum -= a[l];
				l++;
			}
		}
		if(minn != INF)
			printf("%d\n",minn);
		else
			printf("impossible\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值