HDU1786(暴力枚举)

Tempter of the Bone again
Problem Description
Ignatius found some bones in an ancient maze, which fascinated him a lot. However, when he picked them up, the maze began to shake, and Ignatius could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
Suddenly, Ignatius heard a very very cool voice, and he recognize that it comes from Beelzebub feng5166:“I know that you like bone, and even I know your nick name is wishingbone. Today, I give you a chance to survive: there are N kinds of bones here and the number of each kind bone is enough, their weights are Wi pounds (1<=i<=N), your bag has a volume of M pounds, and I also know that you will spend 3 seconds time when you pick up any one bone. Today, you must fill up your bag as quick as you can, otherwise, the maze is your place of the death!”.
Oh, my god! Can the poor Ignatius survive? Please help him!
Note: You are guarantied that solution always exist for every test case.

Input
The input consists of multiple test cases. The first line of each test case contains two integers N and M (1 < N < 10; 0 < M < 1000000000), which denote the kinds of the bone and the capacity of the bag respectively. The next line give N integers W1…Wn (1<=wi<=100), which indicate the weights of bones
The input is terminated with two 0’s. This test case is not to be processed.

Output
For each test case, print the minimal time Ignatius will spend when he can survive. One line per case.

Sample Input
2 20
1 5
0 0

Sample Output
12
(代码来自学长)
简单来说就是在一定范围内暴力穷举

#include <iostream>
#include <cstdio>
#include <string>
#include <stack>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
int n; 
ll m;
int w[100];
bool cmp(int a, int b) { return a > b; }
bool f(ll m, ll i, int k)
{
	if (k >= n) return false;
	else if (m > w[k] * i) return false;
	else if (m == w[k] * i) return true;
	else 
	 for (ll j = m / w[k]; j >= 0; --j)
	 {
		if (f(m - w[k] * j, i - j, k + 1)) return true;
	 }
	return false;
}
int main()
{
	while(cin >> n >> m)
	{
		if (!n && !m) break;
		for (int i = 0; i < n; ++i) scanf("%d", &w[i]);
		sort(w, w+n, cmp);
		ll l = m / w[0], h = m / w[n - 1];
		for (ll i = l; i <= h; ++i)
		{
			if (f(m, i, 0))
			{
				cout << i * 3 << endl;
				break;
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值