Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
…#.
…#
…
…
…
…
…
#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.
…
11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output
45
59
6
13
简单,不多说,代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int count;
int W,H,x1,y1;
int r[22][22];
int vis[22][22];
char ch;
void dfs(int x,int y){
if((!vis[x][y])&&r[x][y]) {
vis[x][y]=1;
count=count+1;
dfs(x-1,y);
dfs(x+1,y);
dfs(x,y-1);
dfs(x,y+1);
}
}
int main() {
while(cin>>W>>H&&(W!=0&&H!=0)){
count=0;
memset(vis,0,sizeof(vis));
memset(r,0,sizeof(r));
for(int i=1;i<=H;i++){
for(int j=1;j<=W;j++){
scanf(" %c",&ch);
if(ch=='@') {
x1=i;
y1=j;
r[i][j]=1;
}
else if(ch=='.'){
r[i][j]=1;
}
}
}
dfs(x1,y1);
printf("%d\n",count);
}
return 0;
}