Apple Tree(树状数组+dfs序+邻接表数组(链式前向星) )

本文介绍了如何利用树状数组和DFS序解决一个关于苹果树的编程问题。该问题涉及树的分支连接,苹果生长与采摘,以及查询子树内苹果总数的请求。通过将问题转化为点修改和区间查询,可以有效利用树状数组进行求解。
摘要由CSDN通过智能技术生成

链接:http://poj.org/problem?id=3321

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

 

 

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"Q x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

 

题目大意:
一棵树上长了苹果,每一个树枝节点上有长苹果和不长苹果两种状态,有两种操作,一种操作能够改变树枝上苹果的状态,另一种操作询问某一树枝节点及以下的所有的苹果有多少。

 

思路:在dfs序中,子树处于一个连续区间中。所以这题可以转化为:点修改,区间查询。可转化树状数组来处理。

 

代码:

#include<iostream>
using namespace std;
const int maxn=210100;
struct node
{
    int to;
    int next;
}e[maxn];
char s;int x;
int in[maxn],out[maxn],c[maxn],cnt;
int n,m,tot,head[maxn],vis[maxn];
void add_edge(int u,int v)
{
    tot++;
    e[tot].to=v;
    e[tot].next=head[u];
    head[u]=tot;
}
int lowbit(int x)
{
    return x&(-x);
}
void dfs(int x)
{
    in[x]=++cnt;
    for(int i=head[x];i;i=e[i].next)
    dfs(e[i].to);
    out[x]=cnt;
}
void update(int x,int add)
{
    while(x<=n)
    {
        c[x]+=add;
        x+=lowbit(x);
    }
}
int sum(int x)
{
    int s=0;
    while(x>0)
    {
        s+=c[x];
        x-=lowbit(x);
    }
    return s;
}
int main()
{
    int a,b;
    cin>>n;
    for(int i=1;i<n;i++)
    {
        cin>>a>>b;
        add_edge(a,b);
    }
    dfs(1);
    for(int i=1;i<=n;i++)
    update(in[i],1),vis[i]=1;
    cin>>m;
    for(int i=1;i<=m;i++)
    {
        cin>>s>>x;
        if(s=='C')
        {
            if(vis[x])update(in[x],-1);
            else update(in[x],1);
            vis[x]=1-vis[x];
        }
        if(s=='Q')
        cout<<sum(out[x])-sum(in[x]-1)<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值