HDU 3336 Count the string(KMP:求一个字符串所有前缀在这个字符串中出现的次数总和)

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

 

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

 

Sample Input

1
4
abab

 

Sample Output

6

 

题意:

给定一个字符串,找出他的所有前缀,输出这些前缀在这个字符串中出现的次数总和

 

思路:

KMP中对next数组的理解,for(int i=1;i<=m;i++),如果f[i]不为0,则证明字符串的某一段和某一前缀相同,则ans加2;如果f[i]为0,则证明不存在字符串的某一段与某一前缀相同,则ans加1

 

 

代码:

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXM=200000+100;
const int MOD=10007;
char P[MAXM];
int f[MAXM],dp[MAXM];
int m;
void getFail(char *P,int *f)
{
    f[0]=f[1]=0;
    for(int i=1;i<m;i++)
    {
        int j=f[i];
        while(j && P[i]!=P[j]) j=f[j];
        f[i+1] = (P[i]==P[j])? j+1:0;
    }
}
int main()
{
    int k;
    scanf("%d",&k);
    while(k--)
    {
        scanf("%d %s",&m,P);
        getFail(P,f);
        int ans=0;
        for(int i=1;i<=m;i++)
        {
            if(f[i]!=0)
                ans+=2;
            else
                ans+=1;
        }
        ans%=MOD;
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值