HDU 3374 String Problem(KMP中求最小循环节出现的次数+最大最小表示法)

Problem Description

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

 

Input

  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

 

Output

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

 

Sample Input

abcder
aaaaaa
ababab

 

Sample Output

1 1 6 1
1 6 1 6
1 3 2 3

 

题意:

首先介绍一下最大最小表示法

比如一个字符串abcde,那么求该串的同构串中字典序最小的那个就是最小表示法,同构串就是每次将串整体循环移动一位形成的新串。例如前面那个串的同构串有bcdea,cdeab,deabc,eabcd,求其字典序中最小的那个串就是最小表示法,同理可得最大表示法

题意:给你一个字符串,让你求最小表示法的开始位置(字符串从1开始编号)和最小循环节数量;最大表示法的开始位置(字符串从1开始编号)和最小循环节数量

 

思路:

注意:对于一个字符串的任何同构串,它们的最小循环节虽然不一样,但最小循环节都是由相同的字母组成的,并且最小循环节的数量是一样的。

可以以abcabc为例,其最小循环节abc

同构串:bcabca,其最小循环节bca

同构串:cabcab,其最小循环节cab

同构串:abcabc,其最小循环节abc

 

最小最大表示法:怎么求最小表示法的开始位置(字符串从0开始编号)和最大表示法的开始位置(字符串从0开始编号);

                             怎么求最大(小)的子串排第几

最小最大表示法------时间复杂度O(n)

//最小表示法
int get_minstring(char *s)
{
    int len=strlen(s);
    int i=0,j=1,k=0;
    while(i<len&&j<len&&k<len)
    {
        int t=s[(i+k)%len]-s[(j+k)%len];
        if(t==0)
            k++;
        else
        {
            if(t>0)
                i+=k+1;
            else
                j+=k+1;
            if(i==j) j++;
            k=0;
        }
    }
    return min(i,j);
}

//最大表示法
int get_maxstring(char *s)
{
    int len=strlen(s);
    int i=0,j=1,k=0;
    while(i<len&&j<len&&k<len)
    {
        int t=s[(i+k)%len]-s[(j+k)%len];
        if(t==0)
            k++;
        else
        {
            if(t>0)
                j+=k+1;
            else
                i+=k+1;
            if(i==j) j++;
            k=0;
        }
    }
    return min(i,j);
}

 

代码:

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXM=1000017;
char P[MAXM];
int f[MAXM],dp[MAXM];
int m;
void getFail(char *P,int *f)
{
    f[0]=f[1]=0;
    for(int i=1;i<m;i++)
    {
        int j=f[i];
        while(j && P[i]!=P[j]) j=f[j];
        f[i+1] = (P[i]==P[j])? j+1:0;
    }
}
//最小表示法
int get_minstring(char *s)
{
    int len=strlen(s);
    int i=0,j=1,k=0;
    while(i<len&&j<len&&k<len)
    {
        int t=s[(i+k)%len]-s[(j+k)%len];
        if(t==0)
            k++;
        else
        {
            if(t>0)
                i+=k+1;
            else
                j+=k+1;
            if(i==j) j++;
            k=0;
        }
    }
    return min(i,j);
}

//最大表示法
int get_maxstring(char *s)
{
    int len=strlen(s);
    int i=0,j=1,k=0;
    while(i<len&&j<len&&k<len)
    {
        int t=s[(i+k)%len]-s[(j+k)%len];
        if(t==0)
            k++;
        else
        {
            if(t>0)
                j+=k+1;
            else
                i+=k+1;
            if(i==j) j++;
            k=0;
        }
    }
    return min(i,j);
}

int main()
{
    while(scanf("%s",P)!=EOF)
    {
        m=strlen(P);
        getFail(P,f);
        int tt=m-f[m];
        int num=1;
        if(m%tt==0)
        {
            num=m/tt;
        }
        int posmin = get_minstring(P);
        int posmax = get_maxstring(P);
        printf("%d %d %d %d\n",posmin+1,num,posmax+1,num);
    }
    return 0;
}

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值