hdu 1058:Humble Numbers(动态规划 DP)

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

 

 

 Input 

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

 

 Output 

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output

 

Sample Input 

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

 

 Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

 

思路:

后面的Humble数总可以用前面求得的某个Humble数乘以{2,3,5,7}中的一个求得。

需要注意的是输出需要按序数的规则输出,个位数是1、2、3的后缀分别是st、nd、rd,但是后两位为11、12、13的数例外(例如11、12、13、111、112、113),它们的后缀是th。其余数后缀均为th。

 

代码:

#include <iostream>
using namespace std;
int a[6000];
int Min(int a,int b,int c,int d)
{
    int t;
    t = a<b?a:b;
    t = t<c?t:c;
    t = t<d?t:d;
    return t;
}
int main()
{
    int n;
    a[1] = 1;
    int a1=1,a2=1,a3=1,a4=1;
    int e1,e2,e3,e4;
    for(int i=2;i<6000;i++){
        e1 = a[a1]*2;
        e2 = a[a2]*3;
        e3 = a[a3]*5;
        e4 = a[a4]*7;
        a[i] = Min(e1,e2,e3,e4);
        if(a[i]==e1)
            a1++;
        if(a[i]==e2)
            a2++;
        if(a[i]==e3)
            a3++;
        if(a[i]==e4)
            a4++;
    }
    while(cin>>n){
        if(n==0)
            break;
        if(n%100==11 || n%100==12 || n%100==13)
            cout<<"The "<<n<<"th humble number is "<<a[n]<<'.'<<endl;
        else {
            int t = n%10;
            switch(t){
                case 0:cout<<"The "<<n<<"th humble number is "<<a[n]<<'.'<<endl;break;
                case 1:cout<<"The "<<n<<"st humble number is "<<a[n]<<'.'<<endl;break;
                case 2:cout<<"The "<<n<<"nd humble number is "<<a[n]<<'.'<<endl;break;
                case 3:cout<<"The "<<n<<"rd humble number is "<<a[n]<<'.'<<endl;break;
                default:cout<<"The "<<n<<"th humble number is "<<a[n]<<'.'<<endl;break;
            }
        }
    }
    return 0;
}

 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值