POJ 1905 Expanding Rods(二分)

该博客介绍了如何解决一道编程题,题目涉及热膨胀问题。给定初始长度、温度变化和热膨胀系数,计算细杆加热后的中心位移。通过二分法找到满足条件的精确答案,并提供了样例输入和输出,以及解题思路和代码实现。
摘要由CSDN通过智能技术生成

Problem Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.

 

Input    

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

 

 

Output 

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

 

Sample Input 

1000 100 0.0001

15000 10 0.00006

10 0 0.001

-1 -1 -1

 

Sample Output 

61.329

225.020

0.000

 

题意: 

当一根长度为l的细杆被加热n度时,它会扩展到一个新的长度l'=(1+n*c)*l,其中c是热膨胀系数。              

当一根细杆安装在两个实心壁上然后加热时,它会膨胀并呈圆形节段,原来的杆是节段的弦。            

 你的任务是计算杆中心位移的距离。

 

思路:

如图,蓝色为杆弯曲前,长度为L。  红色为杆弯曲后,长度为s。

依题意知 ,S=(1+n*C)*L,又从图中得到三条关系式;

(1)      θr = 1/2*s

(2)      sinθ= 1/2*L/r

(3)       r^2 – ( r – h)^2 = (1/2*L)^2

化简得:

h的范围为  0<=h<1/2L

这样每次利用下界low和上界high就能得到中间值mid,寻找最优的mid使得(2)式左右两边差值在精度范围之内,那么这个mid就是h

 

代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<iomanip>
using namespace std;
int main()
{

    double l,n,c;
    while(cin>>l>>n>>c)
    {
       if(l<0&&n<0&&c<0)
       break;
       double low=0.0;
       double high=0.5*l;
       double s=(1+n*c)*l;
       double mid;
       while(high-low>1e-6)
       {
           mid=(low+high)/2;
           double r=(4*mid*mid+l*l)/(8*mid);
           double t=2*r*asin(l/(2*r));
           if(t<s)
           low=mid;
           else
            high=mid;
       }
       cout<<fixed<<setprecision(3)<<mid<<endl;
     }
     return 0;
}

 

 

 

 

 

 


 

 

 


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值