PAT (Advanced Level) Practise 1001. A+B Format (20)

这里写图片描述
1001. A+B Format (20)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input

-1000000 9

Sample Output

-999,991

/*
 * 题意大概就是算出a+b,然后从小数点往前每三位加一个,
 * 我的思路是先反转字符串,然后从头往后遍历加,输出的时候再反转回来
 * 注意处理负数前面的负号
 */
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        int a=input.nextInt();
        int b=input.nextInt();
        int c=a+b;
        boolean smaller0;
        if (c>=0) {
            smaller0=false;
        }else {
            smaller0=true;
        }
        String result=Math.abs(c)+"";
        //String result="13000000";
        StringBuffer sb1=new StringBuffer(result);
        StringBuffer sb2=new StringBuffer();
        result=sb1.reverse().toString();

        for (int i = 0; i < result.length(); i++) {
            if ((i+3)%3==0&&i!=0) {
                sb2.append(",");
            }
            sb2.append(result.charAt(i));
        }
        System.out.println(smaller0?"-"+sb2.reverse():sb2.reverse());
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值