POJ-1724 ROAD

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.
Input
The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
S is the source city, 1 <= S <= N
D is the destination city, 1 <= D <= N
L is the road length, 1 <= L <= 100
T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.
Output
The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.
Sample Input
5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
Sample Output
 

11

用优先队列,在费用可行的情况下,不断松弛路径。其实就是dijkstra算法的队列优化(啊哈书上有)
先按道路长短(道路越短优先级越高)判断优先级,若道路长度一样则按花费(花费越少,优先级越高)判断优先级
不断把能够到达并且符合费用要求的点进队,则每次出队的点就是更新后符合要求的点
若N点能够出队,则证明此时路径最短且符合费用要求.若最终N未出队,则证明没有符合费用要求的最短路径.

#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
#define N 10010

int vis[N],k,n,r,flag;
struct node
{
    int u,v,w,c,head;
} que[N];
struct cmp
{
    int d,val,cos;
    friend bool operator < (cmp a,cmp b) //重载
    {
        if(a.val==b.val)
            return a.cos > b.cos; //在这里'>'是从小到大排列
        return a.val > b.val;
    }
};

void dijkstra()
{
    priority_queue<cmp>Q;
    cmp now,tmp;
    now.d=1;
    now.val=0;
    now.cos=0;
    Q.push(now);

    while(!Q.empty())
    {
        now=Q.top();
        Q.pop();
        if(now.d==n)
        {
            flag=1;
            printf("%d\n",now.val);
            return ;
        }
        int u=now.d;
        for(int i=vis[u]; i!=-1; i=que[i].head) //如果i=-1,证明这个城市作为起点城市的道路都被遍历过了
        {
            tmp.d=que[i].v;
            tmp.val=now.val+que[i].w;
            tmp.cos=now.cos+que[i].c;
            if(tmp.cos <= k)
                Q.push(tmp);
        }
    }
    if(!flag)
        printf("-1\n");
    return ;
}

int main()
{
    while(~scanf("%d%d%d",&k,&n,&r))
    {
        flag=0;
        memset(vis,-1,sizeof(vis)); //任何一个城市在作为起点城市第一次出现时,它的头结点都为空
        for(int i=0; i<r; i++)
        {
            scanf("%d%d%d%d",&que[i].u,&que[i].v,&que[i].w,&que[i].c);
            que[i].head=vis[que[i].u]; //head里保存的都是上一次u作为起点城市的编号
            vis[que[i].u]=i;
        }
        dijkstra();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值