C++详解 寻路问题:1724 ROADS

题目描述:

N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.
We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

N个城市,编号1到N。城市间有R条单向道路。
每条道路连接两个城市,有长度和过路费两个属性。
Bob有K块钱,他想从城市1走到城市N。问最短共需要走多长的路。如果走不到城市N,输出-1。
2<=N<=100
0<=K<=10000
1<=R<=10000
每条路的长度L,1<=L<=100
每条路的过路费T,0<=T<=100

输入:

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.
The third line contains the integer R, 1 <= R <= 10000, the total number of roads.
Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
S is the source city, 1 <= S <= N
D is the destination city, 1 <= D <= N
L is the road length, 1 <= L <= 100
T is the toll (expressed in the number of coins), 0 <= T <=100
Notice that different roads may have the same source and destination cities.

输出:

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.

样例输入:
5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
样例输出:
11
思路:

从城市1开始dfs整个图,找到所有能到达N的走法,选一个最优的。

代码如下:
#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
int K,N,R;
struct Road{
	int d,L,t;
};
vector<vector<Road> > G(110);
int minLen;
int totalLen;
int totalCost;
int visited[110];
void dfs(int s){
	if(s==N){
		minLen=min(totalLen,minLen);
		return;
	}
	for(int i=0;i<G[s].size();++i){
		Road r=G[s][i];
		if(totalCost+r.t>K)
			continue;
		if(!visited[r.d]){
			totalLen+=r.L;
			totalCost+=r.t;
			visited[r.d]=1;
			dfs(r.d);
			visited[r.d]=0;
			totalLen-=r.L;
			totalCost-=r.t;
		}
	}	
}
int main(){
	cin>>K>>N>>R;
	for(int i=0;i<R;++i){
		int s;		//边的起点 
		Road r;		//边的信息 
		cin>>s>>r.d>>r.L>>r.t;
		if(s!=r.d){
			G[s].push_back(r);
		}
	}
	memset(visited,0,sizeof(visited));
	totalLen=0;
	totalCost=0;
	minLen=1<<30;
	visited[1]=1;
	dfs(1);
	if(minLen<(1<<30)){
		cout<<minLen<<endl;
	}else{
		cout<<"-1"<<endl;
	}
	return 0;
}
运行结果:

超时

优化思路:最优性剪枝

如果当前已经找到的最优路径长度为L,那么在继续搜索的过程中,总长度已经大于等于L的走法,就可以直接放弃了。

优化代码如下:
#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
int K,N,R;
struct Road{
	int d,L,t;
};
vector<vector<Road> > G(110);
int minLen;
int totalLen;
int totalCost;
int visited[110];
void dfs(int s){
	if(s==N){
		minLen=min(totalLen,minLen);
		return;
	}
	for(int i=0;i<G[s].size();++i){
		Road r=G[s][i];
		if(totalCost+r.t>K)
			continue;
		if(!visited[r.d]){
			if(minLen<=totalLen+r.L)
				continue;
			totalLen+=r.L;
			totalCost+=r.t;
			visited[r.d]=1;
			dfs(r.d);
			visited[r.d]=0;
			totalLen-=r.L;
			totalCost-=r.t;
		}
	}	
}
int main(){
	cin>>K>>N>>R;
	for(int i=0;i<R;++i){
		int s;		//边的起点 
		Road r;		//边的信息 
		cin>>s>>r.d>>r.L>>r.t;
		if(s!=r.d){
			G[s].push_back(r);
		}
	}
	memset(visited,0,sizeof(visited));
	totalLen=0;
	totalCost=0;
	minLen=1<<30;
	visited[1]=1;
	dfs(1);
	if(minLen<(1<<30)){
		cout<<minLen<<endl;
	}else{
		cout<<"-1"<<endl;
	}
	return 0;
}
运行结果:

超时

再次优化思路:保存中间计算结果用于最优性剪枝:

minL[k][m]表示:走到城市k时总过路费为m的情况下,最优路径的长度。如果在后续的搜索中,再次走到k时,如果总路费恰好为m,且此时的路径长度已经超过minL[k][m],则不必再走下去了。

优化代码如下:
#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
int K,N,R;
struct Road{
	int d,L,t;
};
vector<vector<Road> > G(110);
int minL[110][10010];
int minLen;
int totalLen;
int totalCost;
int visited[110];
void dfs(int s){
	if(s==N){
		minLen=min(totalLen,minLen);
		return;
	}
	for(int i=0;i<G[s].size();++i){
		Road r=G[s][i];
		if(totalCost+r.t>K)
			continue;
		if(!visited[r.d]){
			if(minLen<=totalLen+r.L)
				continue;
			if(totalLen+r.L>=minL[r.d][totalCost+r.t])
				continue;
			minL[r.d][totalCost+r.t]=totalLen+r.L;
			totalLen+=r.L;
			totalCost+=r.t;
			visited[r.d]=1;
			dfs(r.d);
			visited[r.d]=0;
			totalLen-=r.L;
			totalCost-=r.t;
		}
	}	
}
int main(){
	cin>>K>>N>>R;
	for(int i=0;i<R;++i){
		int s;		//边的起点 
		Road r;		//边的信息 
		cin>>s>>r.d>>r.L>>r.t;
		if(s!=r.d){
			G[s].push_back(r);
		}
	}
	memset(visited,0,sizeof(visited));
	totalLen=0;
	totalCost=0;
	minLen=1<<30;
	visited[1]=1;
	for(int i=0;i<110;++i){
		for(int j=0;j<10010;++j){
			minL[i][j]=1<<30;
		}
	}
	dfs(1);
	if(minLen<(1<<30)){
		cout<<minLen<<endl;
	}else{
		cout<<"-1"<<endl;
	}
	return 0;
}
运行结果:

在这里插入图片描述

另附vector使用方法:

https://blog.csdn.net/weixin_45953673/article/details/104678289

  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

枯木何日可逢春

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值