A Simple Problem with Integers POJ - 3468 (线段树更新查询)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 100000*4+1

long long int lazy[N],sum[N];

void build(int v,int l,int r)
{
    if(l==r)
    {
        scanf("%lld",&sum[v]);
        return ;
    }
    int mid=(l+r)/2;
    build(v*2,l,mid);
    build(v*2+1,mid+1,r);
    sum[v]=sum[v*2]+sum[v*2+1];
}

void pushdown(int v,int l,int r)
{
    int mid=(l+r)/2;
    sum[v*2]+=(mid-l+1)*lazy[v];  //更新v节点的左子节点
    lazy[2*v]+=lazy[v];  //标记v的左子节点
    sum[v*2+1]+=(r-mid)*lazy[v];  //同上
    lazy[2*v+1]+=lazy[v];   //同上
    lazy[v]=0;  //取消v节点的标记
}

void update(int v,int l,int r,int a,int b,int c)
{
    if(l>=a && b>=r)  //若该区间在要更新的区间内,更新该区间,并标记该节点
    {
        sum[v]+=(r-l+1)*c;
        lazy[v]+=c;
        return ;
    }
    if(lazy[v]!=0)
        pushdown(v,l,r);//如果该点被标记过,更新其子节点
    int mid=(l+r)/2;
    if(a<=mid)
        update(v*2,l,mid,a,b,c);
    if(b>mid)
        update(v*2+1,mid+1,r,a,b,c);
    sum[v]=sum[v*2]+sum[v*2+1];
}

long long int query(int v,int l,int r,int a,int b)
{
    if(l>=a && r<=b)
        return sum[v];
    if(lazy[v])  //更新节点
        pushdown(v,l,r);
    long long int mid=(l+r)/2;
    long long int sum=0;
    if(a<=mid)
        sum+=query(v*2,l,mid,a,b);
    if(b>mid)
        sum+=query(v*2+1,mid+1,r,a,b);
    return sum;
}

int main()
{
    long long int t,n,q,a,b,c;
    char k;
    while(~scanf("%lld%lld",&n,&q))
    {
        memset(lazy,0,sizeof(lazy));
        build(1,1,n);
        for(long long int i=0; i<q; i++)
        {
            getchar();
            scanf("%c",&k);

            if(k=='C')
            {
                scanf("%lld%lld%lld",&a,&b,&c);
                update(1,1,n,a,b,c);  //更新区间值
            }
            else if(k=='Q')
            {
                scanf("%lld%lld",&a,&b);
                printf("%lld\n",query(1,1,n,a,b));
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值