Bitset
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12428 Accepted Submission(s): 9564
Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1 2 3
Sample Output
1 10 11
#include<stdio.h>
#include<string.h>
int main()
{
int n,i,m,a[100],p;
while(scanf("%d",&n)!=EOF)
{
i=0;
while(n)
{
a[i]=n%2; //取余运算
m=n/2;
n=m;
i++;
}
for(i=i-1;i>=0;i--)
printf("%d",a[i]);
printf("\n");
}
return 0;
}