Android Studio--低版本如何不使用AndroidX编译

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/weikunyu/article/details/83060263

最近AS升级为3.2.1,根据AS提示升级Gradle后,发现项目使用的是AndroidX作为依赖,并且旧的依赖包也更换为新的AndroidX依赖包,于是项目出现各种问题,集成的Lib无法使用、一些旧功能Lib Api更换过于繁杂,使得项目无法编译。

而AS编译提示比较生硬,瞎跟着提示处理异常,结果发现怎么弄都不行,使用AndroidX也不行,不用也不行·····最后无奈翻墙下发现官方文档已有解决办法······

如下修改项目gradle.properties文件:

#是否使用AndroidX库
android.useAndroidX=false
#是否迁移第三方库
android.enableJetifier=false

 

 

展开阅读全文

没有更多推荐了,返回首页