Fliptile POJ - 3279

题目链接:Fliptile POJ - 3279

===================================================

Fliptile

Time Limit: 2000MS
Memory Limit: 65536K

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2…M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1…M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source:USACO 2007 Open Silver

===================================================

算法:DFS

思路:

  • 暴力枚举第一行的情况(用2进制) 然后每下一行的操作取决于上一行是否存在1

===================================================

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

#define inf 1e9

long long cnt,tt;
int n,m;
char ch;
int ans[20][20],akb[20][20];
bool fk[20][20],jk[20][20];

void init(){
    cnt=inf;
    memset(jk,false,sizeof jk);
    for(int i=1;i<=m;i++)
    for(int j=1;j<=n;j++){
        ch=getchar();
        while(ch=='\n'||ch==' ') ch=getchar();
        if(ch=='1') jk[i][j]=true;
    }
}

void check(int i,int j){
    if(fk[i][j]) fk[i][j]=false;
    else fk[i][j]=true;
    if(fk[i+1][j]) fk[i+1][j]=false;
    else fk[i+1][j]=true;
    if(fk[i+1][j+1]) fk[i+1][j+1]=false;
    else fk[i+1][j+1]=true;
    if(fk[i+1][j-1]) fk[i+1][j-1]=false;
    else fk[i+1][j-1]=true;
    if(fk[i+2][j]) fk[i+2][j]=false;
    else fk[i+2][j]=true;
}

void check2(int i,int j){
    if(fk[i][j]) fk[i][j]=false;
    else fk[i][j]=true;
    if(fk[i][j+1]) fk[i][j+1]=false;
    else fk[i][j+1]=true;
    if(fk[i][j-1]) fk[i][j-1]=false;
    else fk[i][j-1]=true;
    if(fk[i+1][j]) fk[i+1][j]=false;
    else fk[i+1][j]=true;
}

bool go(){
    for(int i=1;i<m;i++)
        for(int j=1;j<=n;j++)
            if(fk[i][j]){
                check(i,j);
                tt++;if(tt>=cnt) return false;
                ans[i+1][j]++;
            }
    for(int j=1;j<=n;j++) if(fk[m][j]) return false;
    return true;
}

void solve(int x){
    tt=0;memset(ans,0,sizeof ans);
    for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
            fk[i][j]=jk[i][j];
    for(int i=0;i<n;i++) if((1<<i)&x) {check2(1,i+1);ans[1][i+1]++;tt++;if(tt>=cnt) return ;}
    if(go()){
        cnt=tt;
        for(int i=1;i<=m;i++)
            for(int j=1;j<=n;j++) akb[i][j]=ans[i][j];
    }
}

int main()
{
    cin>>m>>n;
    init();
    for(int i=0;i<(1<<n);i++) solve(i);
    if(cnt==inf) cout<<"IMPOSSIBLE"<<endl;
    else {
        for(int i=1;i<=m;i++){
            for(int j=1;j<=n;j++)
                cout<<akb[i][j]<<' ';
            cout<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

盐太郎

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值