Find The Multiple POJ - 1426

题目链接:Find The Multiple POJ - 1426

===================================================

Find The Multiple

Time Limit: 1000MS
Memory Limit: 10000K

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source:Dhaka 2002

===================================================

算法:BFS

思路:

  • 余数*10+0/1

===================================================

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>

using namespace std;

int n;
bool fk[201];

struct node{
    int a;
    string str;
};
node k;

int main()
{
    while(cin>>n&&n!=0){
        memset(fk,false,sizeof fk);
        k.a = 1%n;k.str = "1";fk[k.a] = true;
        queue<node> q;q.push(k);
        while(!q.empty()){
            node p = q.front();q.pop();
            int a = p.a;string str = p.str;
            if(a==0) {cout<<str<<endl;break;}
            else{
                node m;
                m.a = a*10%n, m.str = str + "0";
                if(!fk[m.a]) q.push(m),fk[m.a] = true;
                m.a = (a*10+1)%n, m.str = str + "1";
                if(!fk[m.a]) q.push(m),fk[m.a] = true;
            }
        }
    }
    return 0;
}

===================================================

算法:DFS

===================================================

#include <iostream>
#include <cstdio>

using namespace std;

int n,flag;

void dfs(unsigned long long a,int step){
    if(flag||step==50) return ;
    if(a%n==0) {flag = 1;printf("%I64u\n",a);return ;}
    else{
        dfs(a*10,step+1);
        dfs(a*10+1,step+1);
    }
}

int main()
{
    while(~scanf("%d",&n)&&n){
        flag = 0;
        dfs(1,0);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

盐太郎

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值