Pots POJ - 3414

题目链接:Pots POJ - 3414

===================================================

Pots

Time Limit: 1000MS
Memory Limit: 65536K

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
  2. DROP(i) empty the pot i to the drain;
  3. POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i),or the pot i is empty (and all its contents have been moved to thepot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

Source:Northeastern Europe 2002, Western Subregion

===================================================

算法:BFS

知识补充:求两个数最大公约数的函数

int gcd(int a,int b) {return b==0?a:gcd(b,a%b);}

思路:

  • 在于 两个水杯容量x,y 与得水量z的关系 z必须能除掉 gcd(x,y);

===================================================

#include <iostream>
#include <cstring>
#include <string.h>
#include <cstdio>
#include <queue>

using namespace std;

int a,b,c;
bool vis[101][101];

struct node{
    int x,y,num;
}k;

struct mm{
    int number,pre;
}akb[12000];

int gcd(int a,int b) {return b==0?a:gcd(b,a%b);}

void show(int x){
    if(akb[x].pre==-1) return ;
    show(akb[x].pre);
    switch(akb[x].number){
        case 1:puts("FILL(1)");break;
        case 2:puts("FILL(2)");break;
        case 3:puts("POUR(1,2)");break;
        case 4:puts("POUR(2,1)");break;
        case 5:puts("DROP(1)");break;
        case 6:puts("DROP(2)");
    }
}

void bfs(){
    k.x = 0 , k.y = 0 , k.num = 0;
    akb[0].pre = -1;
    vis[0][0]=true;
    queue<node> q;
    q.push(k);
    while(!q.empty()){
        node o = q.front();q.pop();
        int x , y ,num;
        for(int i=1;i<=6;i++){
            if(i==5) x = 0 , y = o.y ;
            else if(i==6) x = o.x , y = 0;
            else if(i==1) x = a , y = o.y;
            else if(i==2) x = o.x , y = b;
            else if(i==3){
                x = o.x - min(o.x , b - o.y);
                y = o.y + min(o.x , b - o.y);
            }
            else{
                x = o.x + min(o.y , a - o.x);
                y = o.y - min(o.y , a - o.x);
            }
            if(vis[x][y]) continue;
            vis[x][y]=true;
            num = o.num + 1;
            akb[x*101+y].number = i;
            akb[x*101+y].pre = o.x*101 + o.y;

            if(x == c || y == c) {cout<<num<<endl;show(x*101+y);return;}

            node f;f.x=x,f.y=y,f.num=num;
            q.push(f);
        }
    }
}

int main()
{
    cin>>a>>b>>c;
    memset(vis,false,sizeof vis);
    if(c%gcd(a,b)) puts("impossible");
    else bfs();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

盐太郎

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值