迷宫问题 POJ - 3984

题目链接:迷宫问题 POJ - 3984

===================================================

迷宫问题

Time Limit: 1000MS
Memory Limit: 65536K

Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

===================================================

算法:BFS

思路:

  • 必有答案 需要一个前缀记录函数

===================================================

#include <iostream>
#include <queue>

using namespace std;

int prex[5][5];
int prey[5][5];
int w[5][5];
int xx[] = {1,0,0,-1};
int yy[] = {0,1,-1,0};

struct node{
    int x,y;
    node(int xx,int yy): x(xx),y(yy) {};
};

void show(int x,int y){
    if(x==-1) return ;
    show(prex[x][y],prey[x][y]);
    cout<<"("<<x<<", "<<y<<")"<<endl;
}

int main()
{
    for(int i=0;i<5;i++) for(int j=0;j<5;j++) cin>>w[i][j];
    prex[0][0] = -1 , prey[0][0] = -1;
    w[0][0] = 1;
    queue<node> q;q.push(node(0,0));
    while(!q.empty()){
        node p = q.front();q.pop();
        int x = p.x, y = p.y;
        for(int i=0;i<4;i++){
            int u = x +xx[i],v = y+yy[i];
            if(u<0||u>=5||v<0||v>=5||w[u][v]==1) continue;
            w[u][v]=1;
            prex[u][v] = x , prey[u][v] = y;
            q.push(node(u,v));
        }
    }
    show(4,4);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

盐太郎

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值