hdu1402 java写法水题_acm hdu p1402 A * B Problem Plus 水题

A * B Problem Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15027    Accepted Submission(s): 2907

Problem Description

Calculate A * B.

Input

Each line will contain two integers A and B. Process to end of file.

Note: the length of each integer will not exceed 50000.

Output

For each case, output A * B in one line.

Sample Input

1

2

1000

2

Sample Output

2

2000

此题用java中的最大精度  既可以求解

package HDU;

import java.math.BigDecimal;

import java.math.BigInteger;

import java.util.Scanner;

public class p1402 {

public static void main(String[] args) {

Scanner sc=new Scanner(System.in);

while(sc.hasNext()){

BigDecimal a=sc.nextBigDecimal();

BigDecimal b=sc.nextBigDecimal();

System.out.println(a.multiply(b));

}

}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值