SGU 107. 987654321 problem

107. 987654321 problem

time limit per test: 0.5 sec. 
memory limit per test: 4096 KB

For given number N you must output amount of N-digit numbers, such, that last digits of their square is equal to 987654321.

Input

Input contains integer number N (1<=N<=106)

Output

Write answer to the output.

Sample Input

8

Sample Output

0

一个数平方的最后N位数只有这个数的最后N位数决定.。。。。。。。


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    int n;

while(cin>>n)
{
    if(n<9)
        cout<<0<<endl;
    else if(n==9)
        cout<<8<<endl;
    else if(n==10)
        cout<<72<<endl;
    else
    {
        n-=10;
        printf("72");
        while(n--)
        {
            printf("0");
        }
        cout<<endl;
    }
}
    return 0;
}
* This source code was highlighted by YcdoiT. ( style: Codeblocks )


转载于:https://www.cnblogs.com/CKboss/p/3350899.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值