博弈论

                Coin Game

After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.


The game goes like this:
Two players start the game with a circle of n coins.
They take coins from the circle in turn and every time they could take 1~K continuous coins.
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game.
Suppose that those two players always take the best moves and never make mistakes.
Your job is to find out who will definitely win the game.

 

 

Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=10 9,1<=K<=10).
 

 

Output
For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
 

 

Sample Input
2
3 1
3 2
 
Sample Output
Case 1: first
Case 2: second
 
题目大意: 将硬币1到硬币n呈圆形摆放,首尾相接,(如上图),A,B两人轮流取一些枚硬币,硬币的数量 不超过K并且 必须连续,(连续即所取硬币编号连续)谁取走最后一枚硬币谁就获胜;T组样例,每组样例输入n,k,输出获胜者。
 
分析:博弈论的题,师哥说是对称博弈,B必胜的套路是将所有的硬币分成对称的两部分,之后A怎么取,B就怎么取,这样B一定能取到最后一枚硬币。
具体到此题:
三种情况:
  1. A第一次全部取完 A胜
  2. B不能将所有的硬币分成对称的两部分。
  3. B完成套路。
代码实现:
#include <stdio.h>
int main()
{
    int e,i;
    scanf("%d",&e);
    for(i=1;i<=e;i++)
    {
        int n,k,d=0;
        scanf("%d%d",&n,&k);
        if(n<=k)
            d=1;
        else
        {
            if(n==1|| (n==3&&k==1) || (n>3&&n%2!=0&&k==1) )
                d=1;
            else
                d=2;
        }
        if(d==1)
            printf("Case %d: first\n",i);
        else
            printf("Case %d: second\n",i);
    }
    return 0;
}

 


 

转载于:https://www.cnblogs.com/coder-tcm/p/8666908.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值