hdu5222(拓扑排序+并查集)

Exploration

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1416    Accepted Submission(s): 388


Problem Description
Miceren likes exploration and he found a huge labyrinth underground! 

This labyrinth has  N caves and some tunnels connecting some pairs of caves. 

There are two types of tunnel, one type of them can be passed in only one direction and the other can be passed in two directions. Tunnels will collapse immediately after Miceren passing them. 

Now, Miceren wants to choose a cave as his start point and visit at least one other cave, finally get back to start point. 

As his friend, you must help him to determine whether a start point satisfing his request exists.
 

Input
The first line contains a single integer  T, indicating the number of test cases.

Each test case begins with three integers  N, M1, M2, indicating the number of caves, the number of undirectional tunnels, the number of directional tunnels. 

The next  M1 lines contain the details of the undirectional tunnels. Each line contains two integers  u, v meaning that there is a undirectional tunnel between  u, v. ( u  v

The next  M2 lines contain the details of the directional tunnels. Each line contains integers  u, v meaning that there is a directional tunnel from  u to  v. ( u  v)

T is about 100.

1  N,M1,M2  1000000.

There may be some tunnels connect the same pair of caves.

The ratio of test cases with  N > 1000 is less than 5%.
 

Output
For each test queries, print the answer. If Miceren can do that, output "YES", otherwise "NO".
 

Sample Input
 
  
2 5 2 1 1 2 1 2 4 5 4 2 2 1 2 2 3 4 3 4 1
 

Sample Output
 
  
YES NO
Hint
If you need a larger stack size, please use #pragma comment(linker, "/STACK:102400000,102400000") and submit your solution using C++.


此题题意:有双向桥和单向桥,走过每座桥之后该桥都会塌,问该图里面是否存在回路(就是所谓的环)

分析:

由于有双向桥,用并查集来处理双向桥的话,如果一条没有连接的边的两个点的父亲节点相同说明肯定有通路= =这是第一种情况。

然后就是剩下的单向桥,因为将双向桥用并查集连接起来了,所以接下来就相当于查找单相桥是否存在有向回路,判断有向回路的话就直接拓扑排序来查看是否能进行拓扑排序就ok!


#pragma comment(linker, "/STACK:102400000,102400000")
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
const int maxn=1000010,M=1000010;
int head[maxn],ip,rd[maxn],f[maxn];
int x[M],y[M];char c[M];
struct data
{
    int v,next;
}tu[M];
void init(int n)
{
    memset(head,-1,sizeof(head));
    ip=0;
    for(int i=0;i<=n;i++)///注意这里的等号!!!
        f[i]=i,rd[i]=0,head[i]=-1;
}
void add(int u,int v)
{
    tu[ip].v=v,tu[ip].next=head[u],head[u]=ip++;
}
int fa(int x)
{
    if(f[x]!=x)
        f[x]=fa(f[x]);
    return f[x];
}
int s;
void topu(int n)
{
    queue<int>q;
    for(int i=1;i<=n;i++)///注意容易错!从0开始还是从1!
    {
        if(!rd[i])
        {q.push(i);}
    }
    s=0;
    while(!q.empty())
    {
        int tem=q.front();
        q.pop();
        s++;
        for(int i=head[tem];i!=-1;i=tu[i].next)
        {
            int hh=tu[i].v;
            rd[hh]--;
            if(!rd[hh])
                q.push(hh);
        }
    }
    //printf("%d\n",s);
    if(s<n)
        printf("YES\n");
    else printf("NO\n");
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m1,m2;
        cin>>n>>m1>>m2;
        init(n);
        int flag=0;
        for(int i=0;i<m1;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(fa(x)!=fa(y))
                f[fa(x)]=fa(y);
            else
                flag=1;
        }
        for(int i=0;i<m2;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(!flag)
            {
            x=fa(x),y=fa(y);
            add(x,y);
            rd[y]++;
            }
        }
        if(flag)
            printf("YES\n");
        else topu(n);
    }
    return 0;
}



转载于:https://www.cnblogs.com/martinue/p/5490467.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值