hdu4135 容斥定理

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3587    Accepted Submission(s): 1419


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

 

Sample Input
2
1 10 2
3 15 5
 

 

Sample Output
Case #1: 5
Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 
#include<stdio.h>
#include<string.h>
using namespace std;
long long a[1000],num;
void prime(long long n)
{
    long long i;
    num=0;
    for(i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            a[num++]=i;
            while(n%i==0)
                n=n/i;
        }
    }
    if(n>1)
        a[num++]=n;
}
long long get(long long m)
{
    long long que[10000],k,t=0,sum=0;
    que[t++]=-1;
    for(int i=0;i<num;i++)
    {
        k=t;
        for(int j=0;j<k;j++)
           que[t++]=que[j]*a[i]*(-1);
    }
    for(int i=1;i<t;i++)
        sum=sum+m/que[i];
    return sum;
}

int main()
{
    long long T,x,y,n,cnt;
    while(scanf("%lld",&T)!=EOF)
    {
        for(int i=1;i<=T;i++)
        {
           scanf("%lld%lld%lld",&x,&y,&n);
           prime(n);
           cnt=y-get(y)-(x-1-get(x-1));
           printf("Case #%d: ",i);
           printf("%lld\n",cnt);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wangmenghan/p/5731019.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值