Pixel density sdut2411 ACM算法设计

Pixel density

Time Limit: 1000MS Memory limit: 65536K

题目描述

 

Pixels per inch (PPI) or pixel density is a measurement of the resolution of devices in various contexts; typically computer displays, image scanners, and digital camera image sensors. Note, the unit is not square inches. Good quality photographs usually require 300 pixels per inch when printed. When the PPI is more than 300(phone), we call it retina screen. Sunnypiggy like the retina screen very much.

 

 

But you know it is expensive for Sunnypiggy and Sunnypiggy’s own smart phone isn’t like that.
I tell you how to calculate the PPI. First we must know how big the mobile phone’s screen is. Then we get the resolution (Hp*Wp) about it. After that we calculate the diagonal resolution in pixels (Dp) and divided by diagonal size in inches. Now you get the answer.
Maybe you knew it, but Sunnypiggy’s math is very bad and he wants you to help him to calculate the pixel density of all the electronic products he dreamed.
 

输入

First you will get an integer T which means the number of test cases, and then Sunnypiggy will tell you the name and type of the electronic products. And you know, Sunnypiggy is a careless boy and some data aren’t standard, just like 04.00 inches or 0800*0480.

输出

Output the answers to Sunnypiggy just like the sample output. Maybe it is not a phone. Sunnypiggy like such a form, although it seems no use. The result should be rounded to 2 decimal places. When it has no screen (0.0 inches) that we define the answer is 0.00(PPI).

示例输入

2
iPhone 4S  3.5 inches 960*640 PHONE
The new iPad  0009.7 inches 2048*1536 PAD

示例输出

Case 1: The phone of iPhone 4S's PPI is 329.65.
Case 2: The pad of The new iPad's PPI is 263.92.

提示

Dp= sqrt(Wp*Wp+Hp*Hp )
Wp is width resolution in pixels, Hp is height resolution in pixels.

来源

2012年"浪潮杯"山东省第三届ACM大学生程序设计竞赛
 
做题一定要慎之又慎,充分理解题意啊 ...
 
#include <iostream>
#include <cmath>
#include <string>
//#include <fstream>
#include <iomanip>
#include <vector>
#include <stdio.h>
using namespace std;

int main()
{
	//fstream cin("in.txt");
	int rowCount = 0;
	cin>>rowCount;	
	cin.ignore(1024,'\n');
	int cases = 1;
	vector<string> vs;
	while (rowCount --)
	{
		//字符串解析
		string str;
		vs.clear();		
		int inchesIndex,wphpIndex,typeIndex,nameBorder;
		for(int i = 0;cin >> str;i++)
		{
			vs.push_back(str);
			if("inches" == str)
			{
				nameBorder = i - 2;
				inchesIndex = i - 1;
				wphpIndex = i + 1;
				typeIndex = wphpIndex + 1;
				continue;
			}
			char c;
			cin.get(c);
			if('\n' == c) break;
		}
		//转换成double
		double inches = 0.0,wp = 0.0,hp = 0.0;
		int flag = 0;
		double p = 10;
		for(int i = 0;i != vs[inchesIndex].size();i++)
		{
			if(vs[inchesIndex][i] == '.')
			{
				flag = 1;
				p = 0.1;
				continue;
			}
			if(flag == 0)//整数部分
			{
				inches *= p;
				inches += vs[inchesIndex][i] - '0';
			}
			else if(flag == 1)
			{
				inches += (vs[inchesIndex][i] - '0') * p;
				p *= 0.1;
			}
		}
		flag = 0; p = 10;
		for(int i = 0; i != vs[wphpIndex].size();i++)
		{
			if('.' == vs[wphpIndex][i])
			{
				flag = 1;
				p = 0.1;
				continue;
			}
			if('*' == vs[wphpIndex][i])
			{
				flag = 0;
				p = 10;
				hp = wp;
				wp = 0.0;
				continue;
			}
			if(1 == flag)
			{
				wp += (vs[wphpIndex][i] - '0') * p;
				p *= 0.1;
			}
			if(0 == flag)
			{
				wp *= p;
				wp += vs[wphpIndex][i] - '0';
			}
		}
		double dp = sqrt(wp*wp + hp*hp);

		cout<<"Case "<<cases++<<": The ";
		//吧type转换成小写
		for(int i = typeIndex;i != vs.size();i ++)
		{
			for(int j = 0;j != vs[i].size();j ++)
			{
				if(vs[i][j] >= 65 && vs[i][j] <= 90)
					printf("%c",vs[i][j] + 32);
				else printf("%c",vs[i][j]);
			}
			cout<<" ";
		}
		cout<<"of";
		for(int i = 0;i <= nameBorder;i ++)
		{
			cout<<" "<<vs[i];
		}
		if(inches <= 1e-9)
			cout<<"'s PPI is "<<0.00<<'.'<<endl;
		else
			cout<<"'s PPI is "<<setprecision(2)<<std::fixed<<dp/inches<<'.'<<endl;
	}
}

 

转载于:https://www.cnblogs.com/ifinver/archive/2013/04/12/3017267.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值