USCAO section 1.4 Number Triangles(DP)

 
 

Number Triangles

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

          7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

PROGRAM NAME: numtri

INPUT FORMAT

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

SAMPLE INPUT (file numtri.in)

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

OUTPUT FORMAT

A single line containing the largest sum using the traversal specified.

SAMPLE OUTPUT (file numtri.out)

30

 
我是用DP做的,从底部往上推:状态方程f[i][j]=max(f[i+1][j],f[i+1][j+1])+map[i][j];
  从顶部往下也行,就是麻烦点;
 
 
 
 
/*
ID:nealgav1
PROG:numtri
LANG:C++
*/
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 1234
using namespace std;
int f[N][N];
int map[N][N];
void dp(int m)
{
  for(int i=1;i<=m;i++)//初始化
    f[m][i]=map[m][i];
    for(int i=m-1;i>=1;i--)
    for(int j=1;j<=i;j++)
    f[i][j]=max(f[i+1][j],f[i+1][j+1])+map[i][j];
}
int main()
{
  int m;
  freopen("numtri.in","r",stdin);
  freopen("numtri.out","w",stdout);
  while(scanf("%d",&m)!=EOF)
  {
    for(int i=1;i<=m;i++)
    for(int j=1;j<=i;j++)
    scanf("%d",&map[i][j]);
    dp(m);
    printf("%d\n",f[1][1]);
  }
}

 
 
 
 
 
USER: Neal Gavin Gavin [nealgav1]
TASK: numtri
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.000 secs, 15240 KB]
   Test 2: TEST OK [0.011 secs, 15240 KB]
   Test 3: TEST OK [0.000 secs, 15240 KB]
   Test 4: TEST OK [0.011 secs, 15240 KB]
   Test 5: TEST OK [0.011 secs, 15240 KB]
   Test 6: TEST OK [0.032 secs, 15240 KB]
   Test 7: TEST OK [0.086 secs, 15240 KB]
   Test 8: TEST OK [0.022 secs, 15240 KB]
   Test 9: TEST OK [0.637 secs, 15240 KB]

All tests OK.

YOUR PROGRAM ('numtri') WORKED FIRST TIME! That's fantastic -- and a rare thing. Please accept these special automated congratulations.

 

Number Triangles Russ Cox

We keep track (in the "best" array) of total for the best path ending in a given column of the triangle. Viewing the input, a path through the triangle always goes down or down and to the right. To process a new row, the best path total ending at a given column is the maximum of the best path total ending at that column or the one to its left, plus the number in the new row at that column. We keep only the best totals for the current row (in "best") and the previous row (in "oldbest").

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>

#define MAXR 1000

int
max(int a, int b)
{
	return a > b ? a : b;
}

void
main(void)
{
	int best[MAXR], oldbest[MAXR];
	int i, j, r, n, m;
	FILE *fin, *fout;

	fin = fopen("numtri.in", "r");
	assert(fin != NULL);
	fout = fopen("numtri.out", "w");
	assert(fout != NULL);

	fscanf(fin, "%d", &r);

	for(i=0; i<MAXR; i++)
		best[i] = 0;

	for(i=1; i<=r; i++) {
		memmove(oldbest, best, sizeof oldbest);
		for(j=0; j<i; j++) {
			fscanf(fin, "%d", &n);
			if(j == 0)
				best[j] = oldbest[j] + n;
			else
				best[j] = max(oldbest[j], oldbest[j-1]) + n;
		}
	}

	m = 0;
	for(i=0; i<r; i++)
		if(best[i] > m)
			m = best[i];

	fprintf(fout, "%d\n", m);
	exit(0);
}

 

转载于:https://www.cnblogs.com/nealgavin/archive/2012/08/09/3206040.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值