2015弱校联盟(1) - C. Censor

C. Censor
Time Limit: 2000ms
Memory Limit: 65536KB

frog is now a editor to censor so-called sensitive words (敏感词).

She has a long text p. Her job is relatively simple – just to find the first occurence of sensitive word w and remove it.

frog repeats over and over again. Help her do the tedious work.
Input
The input consists of multiple tests. For each test:

The first line contains 1 string w. The second line contains 1 string p.

(1≤length of w,p≤5⋅106, w,p consists of only lowercase letter)
Output
For each test, write 1 string which denotes the censored text.
Sample Input

abc
aaabcbc
b
bbb
abc
ab

Sample Output

a

ab

KMP+模拟栈

#include <bits/stdc++.h>
#define LL long long
#define ULL unsigned long long
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)
#define VI vector<int>
#pragma comment(linker, "/STACK:1024000000,1024000000")

using namespace std;

const int Max = 1e6;

char s[Max*5+100];

char c[Max*5+110];

char ans[Max*5+110];

int Next[Max*5+100];

int pre[Max*5+100];

int len1,len2;

void Get_Next()
{
    int i=0,j=-1;
    Next[0]=-1;
    while(i<len1)
    {
        if(j==-1||s[i]==s[j])
        {
            i++;
            j++;
            Next[i]=j;
        }
        else
        {
            j=Next[j];
        }
    }
}

void Kmp()
{
    int k=0;
    int j=0;
    for(int i=0;i<len2;i++,k++)
    {
        ans[k]=c[i];
        while(j>0&&c[i]!=s[j])
        {
            j=Next[j];
        }
        if(c[i]==s[j])
        {
            j++;
        }
        if(j==len1)
        {
            k-=len1;
            if(k==-1) j=0;
            else  j=pre[k];

        }
        if(k!=-1)
        {
            pre[k]=j;
        }
        ans[k+1]=0;
    }
    ans[k+1]=0;
}

int main()
{
    while(~scanf("%s %s",&s,&c))
    {
        len1=strlen(s);
        len2=strlen(c);
        Get_Next();
        Kmp();
        printf("%s\n",ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/juechen/p/5255909.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值