hdoj--2119--Matrix(最小点覆盖)

Matrix

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2319    Accepted Submission(s): 1030


Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.
 

Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.
 

Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.
 

Sample Input
 
  
3 3 0 0 0 1 0 1 0 1 0 0
 

Sample Output
 
  
2
 

Author
Wendell
 

Source

给了一个n*m的矩阵,矩阵元素有0 1,每次可以消除一行或者一列的1,问最少多少次消除全部的1
最少点覆盖=最大匹配,匈牙利算法:
#include<stdio.h>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;
vector<int>map[200];
int pipei[200],used[200];
int find(int x)
{
	for(int i=0;i<map[x].size();i++)
	{
		int y=map[x][i];
		if(!used[y])
		{
			used[y]=1;
			if(!pipei[y]||find(pipei[y]))
			{
				pipei[y]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int n,m;
	while(scanf("%d",&n),n)
	{
		scanf("%d",&m);
		for(int i=1;i<=n;i++)
		{
			map[i].clear();
			pipei[i]=0;
		}
		int a;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				scanf("%d",&a);
				if(a)
					map[i].push_back(j);
			}
		}
		int sum=0;
		for(int i=1;i<=n;i++)
		{
			memset(used,0,sizeof(used));
			sum+=find(i);
		}
		printf("%d\n",sum);
	}
}


转载于:https://www.cnblogs.com/playboy307/p/5273491.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值