hdoj 1498 50 years, 50 colors (二分图--最小点覆盖)

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2299    Accepted Submission(s): 1296


Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.


 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 

Sample Input
  
  
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output
  
  
-1 1 2 1 2 3 4 5 -1
 题目大意:一次举办活动,共有50种颜色的气球,给一个n*n(<100)的矩阵,每个坐标放一种气球,让每个学生先选择一种球,给k次撞球的机会,每次可以撞炸一行或者一列同颜色的球,问k次撞击后,还有那些球没有全被撞炸,按编号从小到大输出
思路:最小点覆盖:每个点的x,y坐标看做两个集合,这个气球看做一条边,只要选择有(x,~)或者(~,y)都可以使这一行或一列消去,所以是最小点覆盖
代码:
#include<cstdio>
#include<cstring>
int a[110][110];
int map[110][110];
int vis[110];
int match[110];
//	开始上面几组数组开成了55,开小了,TEL 
int mark[55];//标记出现的球的编号 
int n;
//	最小点覆盖==最大匹配数 
bool dfs(int x)
{
	int i;
	for(i=1;i<=n;i++)
	{
		if(map[x][i]&&!vis[i])
		{
			vis[i]=1;
			if(!match[i]||dfs(match[i]))
			{
				match[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int getmax()
{
	int i,sum=0;
	for(i=1;i<=n;i++)
	{
		memset(vis,0,sizeof(vis));
		sum+=dfs(i);
	}
	return sum;
}
int main()
{
	int k;
	while(scanf("%d%d",&n,&k),n+k)
	{
		int i,j;
		memset(mark,0,sizeof(mark));
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				scanf("%d",&a[i][j]);
				mark[a[i][j]]=1;
			 } 
		}
		bool flag=0;	//控制输出格式 
		for(int t=1;t<=50;t++)
		{
			if(mark[t])	//对每一种气球 建图 
			{
				memset(map,0,sizeof(map));
				memset(match,0,sizeof(match));
				for(i=1;i<=n;i++)
				{
					for(j=1;j<=n;j++)
					{
						if(a[i][j]==t)
							map[i][j]=1;	
					}
				}
				if(getmax()>k)	// 比较最小点覆盖 与 k的关系  ,>k说明不能全部消去 ,输出 
				{
					if(!flag)
					{
						printf("%d",t);
						flag=1;
					}						
					else
						printf(" %d",t);				
				}			
			}
			
		}
		if(!flag)	// 每种气球在k次的情况下,都可以消去 
			printf("-1\n");
		else
			printf("\n");
	}
	return 0;
 } 

看了好几次,终于差不多了明白的………………

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值