HDU 5645 DZY Loves Balls 水题

DZY Loves Balls

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5645

Description

DZY loves playing balls.

He has n balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it A. Next, without putting A back into the box, he randomly picks another ball from the box, and names it B.

If the number written on A is strictly greater than the number on B, he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.

Input

First line contains t denoting the number of testcases.

t testcases follow. In each testcase, first line contains n, second line contains n space-separated positive integers ai, denoting the numbers on the balls.

(1≤t≤300,2≤n≤300,1≤ai≤300)

Output

For each testcase, output a real number with 6 decimal places.

Sample Input

2
3
1 2 3
3
100 100 100

Sample Output

0.500000
0.000000

Hint

题意

有n个球,你首先拿一个球A,然后不放回,再拿一个球B

问你球A大于球B的概率是多少

题解:

数据范围很小,直接暴力就好了

nlogn的话,写个权值线段树/树状数组就好了

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 301;
int a[maxn];
void solve()
{
    int n;scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    double ans = 0;
    for(int i=1;i<=n;i++)
    {
        int add = 0;
        for(int j=1;j<=n;j++)
            if(a[i]>a[j])add++;
        ans=ans+add;
    }
    printf("%.6f\n",ans/((1.0*n*(n-1))));
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)solve();
}

转载于:https://www.cnblogs.com/qscqesze/p/5310041.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值