B - Frogger POJ - 2253

一道图论题,

首先,英语限制了我的做题,百度翻译垃圾了翻译的不知道是啥,烦得很然后去搜索了大神的博客,

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

       题意大致为:
       (下面的是大神的)

  1. 题目大意求青蛙由起点跳到终点的过程中,在所有的路径中的最大步伐中的最小步伐。题目简单。用Dijkstra算法解,但并非是求最小路径或最  
  2. 小路径长度。这里是Dijkstra算法的变体,结合贪心算法的思想,在走每一步时,选取距离最小(即步伐最小)的那一步走,每一次走都是在上一步  
  3. 的基础之上走的,用一个变量pos记录每次通过的结点,再用一个变量记录已经走了的路径中的最大步伐,当pos等于终点结点的编号时,就停止,输出最大步伐 

说实话题意我真心没有看懂,在参考大神的代码之后大概有点理解

   AC代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn = (int)1e3 + 5;
#define INF 0x3f3f3f3f

struct edge{
	int x,y;
}ss[maxn];
int t;
double map[maxn][maxn],dis[maxn];
int vis[maxn];
double lenn(double x1,double y1,double x2,double y2)
{
	return sqrt(abs(x1 - x2) * abs(x1 - x2) + abs(y1 - y2) * abs(y1 - y2));
}
double get_max(double a,double b)
{
	return a>b?a:b;
}
double dijkstra()
{
	for(int i = 1;i<=t;i++)
	{
		vis[i] = 0;
		dis[i] = map[1][i];
	}
	vis[1] = 1;
	dis[1] = 0.0;
	int pos = 1;
	for(int i = 1;i<t;i++)
	{
		for(int j = 1;j<=t;j++)
		{
			if(!vis[j] && map[pos][j] <INF*1.0 && get_max(dis[pos],map[pos][j])<dis[j])
			{
				dis[j] = get_max(dis[pos] ,map[pos][j]);
			}
		}
		
		double minn = INF * 1.0;
		int v;
		for(int j = 1;j<=t;j++)
		{
			if(!vis[j] && minn > dis[j])
			{
				minn = dis[j];
				v = j;
			}
		}
		vis[v] = 1;
		pos = v;
	}
	return dis[2];
}
int main()
{
	int k = 1;
	while(cin>>t && t)
	{
		for(int i = 1 ; i <= t ; i++)
		{
			scanf("%d %d",&ss[i].x,&ss[i].y);
		}
		memset(vis ,0 ,sizeof(vis));
		memset(map , INF*1.0 ,sizeof(map));
		for(int i = 1;i <= t ; i++)
		{
			for(int j = i+1 ;j <= t ; j++)
			{
				double len = lenn(ss[i].x * 1.0,ss[i].y * 1.0,ss[j].x * 1.0,ss[j].y * 1.0);
				map[i][j] = map[j][i] = len;
			}
		}
		printf("Scenario #%d\n",k++);
		printf("Frog Distance = %.3lf\n\n",dijkstra());
	}
	return 0;
 } 

        

转载于:https://www.cnblogs.com/acer1238/p/9165490.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值