poj 2253 Frogger(dijkstra变形,好题)

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37972 Accepted: 12216

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


题意:

给出两只青蛙的坐标A、B,和其他的n-2个坐标,任一两个坐标点间都是双向连通的。
现在要求求出所有通路的A到B的最大距离(指任意一条通路上最长的边),并把这些最大距离作比较,把最小的一个最大距离作为青蛙的最小跳远距离。



题解:

这题是dijkstra算法的变形,用d[i]表示i点到源点路程上最长的线段,其余的和dijkstra一样。


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<cmath>
using namespace std;
typedef pair<double,int> P;
const int maxn=200+10;
const int inf=0x3f3f3f3f;
double d[maxn],g[maxn][maxn];
int n;
struct node
{
	int x,y;
}a[maxn];

void dijkstra()
{
	priority_queue<pair<double,int> > Q;
	for(int i=1;i<=n;i++) d[i]=inf;
	d[1]=0;
	Q.push(make_pair(-d[1],1));
	while(!Q.empty())
	{
		P cur=Q.top();
		Q.pop();
		int u=cur.second;
		double w=-cur.first;
		for(int v=1;v<=n;v++)
		{
			if(d[v]>max(w,g[u][v]))
			{
				d[v]=max(w,g[u][v]);
				Q.push(make_pair(-d[v],v));
			}
		}
	}
}

double cal(node a,node b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

int main()
{
	int cas=0;
	while(~scanf("%d",&n)&&n)
	{
		memset(g,0,sizeof(g));
		for(int i=1;i<=n;i++) scanf("%d%d",&a[i].x,&a[i].y);
		for(int i=1;i<=n;i++)
		{
			g[i][i]=0;
			for(int j=i+1;j<=n;j++)
			g[i][j]=g[j][i]=cal(a[i],a[j]);
		}
		dijkstra();
		printf("Scenario #%d\nFrog Distance = %.3f\n\n",++cas,d[2]);
	}
}




当然也可以用spfa。


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<cmath>
using namespace std;
typedef pair<double,int> P;
const int maxn=200+10;
const int inf=0x3f3f3f3f;
double d[maxn],g[maxn][maxn];
int n;
struct node
{
    int x,y;
}a[maxn];

int q[maxn],inq[maxn];
void spfa()
{
    for(int i=1;i<=n;i++) d[i]=inf;
    d[1]=0;
    memset(inq,0,sizeof(inq));
    memset(q,0,sizeof(q));
    int front=0,rear=0;
    q[rear++]=1;
    inq[1]=1;
    while(front!=rear)
    {
        int u=q[front++];
        inq[u]=0;
        if(front>=maxn) front=0;
        for(int v=1;v<=n;v++)
        {
            if(d[v]>max(d[u],g[u][v]))
            {
                d[v]=max(d[u],g[u][v]);
                if(inq[v]) continue;
                inq[v]=1;
                q[rear++]=v;
                if(rear>=maxn) rear=0;
            }
        }
    }
}

double cal(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

int main()
{
    int cas=0;
    while(~scanf("%d",&n)&&n)
    {
        memset(g,0,sizeof(g));
        for(int i=1;i<=n;i++) scanf("%d%d",&a[i].x,&a[i].y);
        for(int i=1;i<=n;i++)
        {
            g[i][i]=0;
            for(int j=i+1;j<=n;j++)
                g[i][j]=g[j][i]=cal(a[i],a[j]);
        }
        spfa();
        printf("Scenario #%d\nFrog Distance = %.3f\n\n",++cas,d[2]);
    }
}




其实,这一题也是floyed变体。

定义 f(i,j)为i->j的路径上的最大跳的最小值,

那么f(i,j)=min( f(i,j), max(f(i,k),f(k,j)) ),

o(n^3)


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值