12289 - One-Two-Three

 

 One-Two-Three 

Your little brother has just learnt to write one, two and three, in English. He has written a lot of thosewords in a paper, your task is to recognize them. Note that your little brother is only a child, so he maymake small mistakes: for each word, there might be at most one wrong letter. The word length isalways correct. It is guaranteed that each letter he wrote is in lower-case, and each word he wrote has aunique interpretation.

 

Input 

The first line contains the number of words that your little brother has written. Each of the followinglines contains a single word with all letters in lower-case. The words satisfy the constraints above: atmost one letter might be wrong, but the word length is always correct. There will be at most 10 wordsin the input.

 

Output 

For each test case, print the numerical value of the word.

 

Sample Input 

 

3
owe
too
theee

 

Sample Output 

 

1
2
3
#include<stdio.h>
int main()
{
	char s[6];
	int t,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",s);
		if(s[3]!='\0'){puts("3");continue;}
		if((s[0]=='o'&&s[1]=='n')||(s[0]=='o'&&s[2]=='e')||(s[2]=='e'&&s[1]=='n')) puts("1");
		else puts("2");
	}
	return 0;
}


转载于:https://www.cnblogs.com/snake-hand/archive/2013/06/15/3137521.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值