HDU 3873 Invade the Mars

Invade the Mars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 365768/165536 K (Java/Others)
Total Submission(s): 2141    Accepted Submission(s): 625

Problem Description
It's now the year 21XX,when the earth will explode soon.The evil U.S. decided to invade the Mars to save their lives.
But the childlike Marsmen never keeps any army,because war never take place on the Mars.So it's very convenient for the U.S. to act the action.
Luckily,the Marsmen find out the evil plan before the invadation,so they formed a defense system.The system provides enchantment for some citys,and the enchantment generator for city A maybe set in city B,and to make things worse,both city B and C and more will provide echantment for city A.
The satelite of U.S. has got the map of the Mars.And they knows that when they enter a city,they can destory all echantment generator in this city at once,and they can enter a city only if they has destoryed all enchantment generator for this city,but troops can stay at the outside of the city and can enter it at the moment its echantment is destoryed.Of course the U.S. army will face no resistance because the Mars keep no army,so troops can invade in many way at the same time.
Now the U.S. will invade the Mars,give you the map,your task is to calculate the minimium time to enter the capital of the Mars.
 
Input
The first line contains an integer T,which is the number of test cases.
For each testcase:
The first line contains two integers N and M,1<=N<=3000,1<=M<=70000,the cities is numbered from 1 to N and the U.S. landed on city 1 while the capital of the Mars is city N.
The next M lines describes M paths on the Mars.Each line contains three integers ai,bi and wi,indicates there is a unidirectional path form ai to bi lasts wi minutes(1<=wi<=10^8).
The next N lines describes N citys,the 1+M+i line starts with a integer li,followed with li integers, which is the number of cities has a echantment generator protects city i.
It's guaranteed that the city N will be always reachable.
 
Output
For each case,print a line with a number indicating the minimium time needed to enter the capital of the Mars.
 
Sample Input
1
6 6
1 2 1
1 4 3
2 3 1
2 5 2
4 6 2
5 3 2
0
0
0
1 3
0
2 3 5
 
Sample Output
5
Hint
The Map is like this: We can follow these ways to achieve the fastest speed: 1->2->3,1->2->5,1->4->6.

 

用Dij维护两个量,f和d,f为保护该城市的城市所有被摧毁的最大时间,d为能到达该城市的最小距离。军队能先包围一个城市,等保护它的城市被摧毁了,就可以瞬间占领,所以取f,d中的较大值。

#include <iostream>
#include <cstring>
using namespace std;
const int MAXN = 3000+123;
const int MAXM = 70000+1234;
const int MAXNM = 3000*1510;
int m,n,used,num;
struct Edge{
    int v,next,val;
}edge[MAXM];
struct Edge2{
    int v,next;
}pro[MAXNM];
int head[MAXN];
int first[MAXN];
int rest[MAXN];
int d[MAXN];
int f[MAXN];
bool vis[MAXN];
void add(int a,int b,int c){//
    edge[used].v=b;
    edge[used].val=c;
    edge[used].next=head[a];
    head[a]=used++;
}

void add2(int a,int b){//被a保护的城市
    rest[b]++;//保护b的城市有多少个
    pro[num].v=b;
    pro[num].next=first[a];
    first[a]=num++;
}

void init(){
    num=0;
    used=0;
    memset(head,-1,sizeof(head));
    memset(first,-1,sizeof(first));
    memset(rest,0,sizeof(rest));
    memset(vis,false,sizeof(vis));
    memset(f,0,sizeof(f));
    memset(d,60,sizeof(d));
}

void dij(){
    d[1]=0;
    f[1]=0;
    int minp=1;
    for(int k=1;k<n;k++){
        vis[minp]=true;
        for(int p=first[minp];p!=-1;p=pro[p].next){//被minp保护的城市更新
            rest[pro[p].v]--;
            if(d[minp]>f[pro[p].v]){
                f[pro[p].v]=d[minp];
            }
        }
        for(int p=head[minp];p!=-1;p=edge[p].next){
            int j=edge[p].v;
            if(edge[p].val+d[minp]<d[j]){
                d[j]=edge[p].val+d[minp];
            }
        }
        for(int j=1;j<=n;j++){
            d[j]=f[j]>d[j]?f[j]:d[j];
        }
        minp=0;
        for(int j=2;j<=n;j++){
            if(rest[j]<=0&&!vis[j]){
                if(d[j]<d[minp]){
                    minp=j;
                }
            }
        }
    }
}

int main(){
    int T;
    cin.sync_with_stdio(false);
    cin>>T;
    while(T--){
        cin>>n>>m;
        init();
        int a,b,c;
        for(int i=1;i<=m;i++){
            cin>>a>>b>>c;
            add(a,b,c);
        }
        for(int i=1;i<=n;i++){
            cin>>a;
            for(int j=1;j<=a;j++){
                cin>>b;
                add2(b,i);
            }
        }
        dij();
        cout<<d[n]<<endl;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/xjh-shin/articles/6336945.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值