Invade the Mars HDU - 3873(最短路变体)

It’s now the year 21XX,when the earth will explode soon.The evil U.S. decided to invade the Mars to save their lives.
But the childlike Marsmen never keeps any army,because war never take place on the Mars.So it’s very convenient for the U.S. to act the action.
Luckily,the Marsmen find out the evil plan before the invadation,so they formed a defense system.The system provides enchantment for some citys,and the enchantment generator for city A maybe set in city B,and to make things worse,both city B and C and more will provide echantment for city A.
The satelite of U.S. has got the map of the Mars.And they knows that when they enter a city,they can destory all echantment generator in this city at once,and they can enter a city only if they has destoryed all enchantment generator for this city,but troops can stay at the outside of the city and can enter it at the moment its echantment is destoryed.Of course the U.S. army will face no resistance because the Mars keep no army,so troops can invade in many way at the same time.
Now the U.S. will invade the Mars,give you the map,your task is to calculate the minimium time to enter the capital of the Mars.
Input
The first line contains an integer T,which is the number of test cases.
For each testcase:
The first line contains two integers N and M,1<=N<=3000,1<=M<=70000,the cities is numbered from 1 to N and the U.S. landed on city 1 while the capital of the Mars is city N.
The next M lines describes M paths on the Mars.Each line contains three integers ai,bi and wi,indicates there is a unidirectional path form ai to bi lasts wi minutes(1<=wi<=10^8).
The next N lines describes N citys,the 1+M+i line starts with a integer li,followed with li integers, which is the number of cities has a echantment generator protects city i.
It’s guaranteed that the city N will be always reachable.
Output
For each case,print a line with a number indicating the minimium time needed to enter the capital of the Mars.
Sample Input
1
6 6
1 2 1
1 4 3
2 3 1
2 5 2
4 6 2
5 3 2
0
0
0
1 3
0
2 3 5
Sample Output
5

这题实力被坑死,只能怪我英语不好吧,unidirectional居然是单向的意思,一直以为是无向的。。。。。。。
还有这题只能用优先队列来做,因为要保证只更新一次,并且就是已经是最小的(对于没有负边的情况的确是这样)。。。普通队列做不对

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
int n,m;
const long long INF=92233720368547;
struct node1
{
    int to;
    int w;
}edge[70005];
vector<int> graph[3005];
int limit[3005];
vector<int> force[3005];
bool vis[3005];
long long dis[3005];
long long can[3005];
struct node
{
    int y;
    long long l;
    node(int a,long long b):y(a),l(b){}
    friend bool operator < (node a,node b)
    {
        return a.l>b.l;
    }
};
priority_queue<node>que;
void spfa()
{
    for(int i=2;i<=n;i++)
        dis[i]=INF;
    memset(can,0,sizeof(can));
    memset(vis,false,sizeof(vis));
    dis[1]=0;
    que.push(node(1,0));
    while(!que.empty())
    {
        //cout<<"haha"<<endl;
        int u=que.top().y;
        que.pop();
        if(vis[u])continue;//只访问一次
        vis[u]=true;
        for(int i=0;i<force[u].size();i++)
        {
            int v=force[u][i];
            limit[v]--;
            can[v]=max(can[v],dis[u]);
            if(limit[v]<=0&&dis[v]!=INF)
            {
                dis[v]=max(dis[v],can[v]);//必须先和can比较
                que.push(node(v,dis[v]));
            }
        }
        for(int i=0;i<graph[u].size();i++)
        {
            int index=graph[u][i];
            int v=edge[index].to;
            if(dis[v]>dis[u]+edge[index].w)
            {
                dis[v]=dis[u]+edge[index].w;
                if(limit[v]<=0)
                    que.push(node(v,dis[v]));
            }
        }
    }
}
int main()
{
    int t;
    int x,y,w;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            graph[i].clear(),force[i].clear();
        memset(limit,0,sizeof(limit));
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&x,&y,&w);
            edge[i].to=y;
            edge[i].w=w;
            graph[x].push_back(i);
        }
        int num;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num);
            limit[i]=num;
            while(num--)
            {
                scanf("%d",&x);
                force[x].push_back(i);
            }
        }
        spfa();
        printf("%lld\n",dis[n]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值