hdu 2425 Hiking Trip (bfs+优先队列)

Problem Description
Hiking in the mountains is seldom an easy task for most people, as it is extremely easy to get lost during the trip. Recently Green has decided to go on a hiking trip. Unfortunately, half way through the trip, he gets extremely tired and so needs to find the path that will bring him to the destination with the least amount of time. Can you help him?
You've obtained the area Green's in as an R * C map. Each grid in the map can be one of the four types: tree, sand, path, and stone. All grids not containing stone are passable, and each time, when Green enters a grid of type X (where X can be tree, sand or path), he will spend time T(X). Furthermore, each time Green can only move up, down, left, or right, provided that the adjacent grid in that direction exists.
Given Green's current position and his destination, please determine the best path for him. 
 

 

Input
There are multiple test cases in the input file. Each test case starts with two integers R, C (2 <= R <= 20, 2 <= C <= 20), the number of rows / columns describing the area. The next line contains three integers, V P, V S, V T (1 <= V P <= 100, 1 <= V S <= 100, 1 <= V T <= 100), denoting the amount of time it requires to walk through the three types of area (path, sand, or tree). The following R lines describe the area. Each of the R lines contains exactly C characters, each character being one of the following: ‘T’, ‘.’, ‘#’, ‘@’, corresponding to grids of type tree, sand, path and stone. The final line contains four integers, S R, S C, T R, T C, (0 <= S R < R, 0 <= S C < C, 0 <= T R < R, 0 <= T C < C), representing your current position and your destination. It is guaranteed that Green's current position is reachable – that is to say, it won't be a '@' square.
There is a blank line after each test case. Input ends with End-of-File.
 

 

Output
For each test case, output one integer on one separate line, representing the minimum amount of time needed to complete the trip. If there is no way for Green to reach the destination, output -1 instead.
 

 

Sample Input
4 6 1 2 10 T...TT TTT### TT.@#T ..###@ 0 1 3 0 4 6 1 2 2 T...TT TTT### TT.@#T ..###@ 0 1 3 0 2 2 5 1 3 T@ @. 0 0 1 1
 

 

Sample Output
Case 1: 14
Case 2: 8
Case 3: -1
 
//挺简单的,之前忘记做标记了,结果MLE了
 
#include <iostream>
#include <queue>
#include <cstring>
using namespace std;
int n,m;
int vp,vs,vt;
int k1,k2,e1,e2;
char data[25][25];
int visit[25][25];
int to[4][2]={{1,0},{-1,0},{0,1},{0,-1}};

struct node
{
    int x,y;
    int step;
    friend bool operator < (node a,node b)
    {
        return a.step>b.step;
    }
};

int go(int i,int j)
{
    if(0<=i&&i<n&&0<=j&&j<m&&data[i][j]!='@'&&visit[i][j]==0)
    return 1;
    else return 0;
}

int bfs()
{
    node st,ed;
    priority_queue<node> q;
    st.x=k1;
    st.y=k2;
    st.step=0;
    q.push(st);
    memset(visit,0,sizeof(visit));
    visit[k1][k2]=1;
    while(!q.empty())
    {
        st=q.top();
        q.pop();
        if(st.x==e1&&st.y==e2)
        {
            cout<<st.step<<endl;
            return 0;
        }
        for(int i=0;i<4;i++)
        {
            ed.x=st.x+to[i][0];
            ed.y=st.y+to[i][1];
            if(go(ed.x,ed.y))
            {
                visit[ed.x][ed.y]=1;
                if(data[ed.x][ed.y]=='T')
                ed.step=st.step+vt;
                if(data[ed.x][ed.y]=='.')
                ed.step=st.step+vs;
                if(data[ed.x][ed.y]=='#')
                ed.step=st.step+vp;
                q.push(ed);
            }
        }
    }
    cout<<"-1"<<endl;
    return 0;
}

int main()
{
    int k=0;
    while(cin>>n>>m)
    {
        k++;
        cin>>vp>>vs>>vt;
        for(int i=0;i<n;i++)
         for(int j=0;j<m;j++)
          cin>>data[i][j];
        cin>>k1>>k2>>e1>>e2;
        cout<<"Case "<<k<<": ";
        bfs();
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/nefu929831238/p/5540371.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值