2425 Hiking Trip

Hiking Trip

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1374    Accepted Submission(s): 607


Problem Description
Hiking in the mountains is seldom an easy task for most people, as it is extremely easy to get lost during the trip. Recently Green has decided to go on a hiking trip. Unfortunately, half way through the trip, he gets extremely tired and so needs to find the path that will bring him to the destination with the least amount of time. Can you help him?
You've obtained the area Green's in as an R * C map. Each grid in the map can be one of the four types: tree, sand, path, and stone. All grids not containing stone are passable, and each time, when Green enters a grid of type X (where X can be tree, sand or path), he will spend time T(X). Furthermore, each time Green can only move up, down, left, or right, provided that the adjacent grid in that direction exists.
Given Green's current position and his destination, please determine the best path for him. 
 

Input
There are multiple test cases in the input file. Each test case starts with two integers R, C (2 <= R <= 20, 2 <= C <= 20), the number of rows / columns describing the area. The next line contains three integers, V P, V S, V T (1 <= V P <= 100, 1 <= V S <= 100, 1 <= V T <= 100), denoting the amount of time it requires to walk through the three types of area (path, sand, or tree). The following R lines describe the area. Each of the R lines contains exactly C characters, each character being one of the following: ‘T’, ‘.’, ‘#’, ‘@’, corresponding to grids of type tree, sand, path and stone. The final line contains four integers, S R, S C, T R, T C, (0 <= S R < R, 0 <= S C < C, 0 <= T R < R, 0 <= T C < C), representing your current position and your destination. It is guaranteed that Green's current position is reachable – that is to say, it won't be a '@' square.
There is a blank line after each test case. Input ends with End-of-File.
 

Output
For each test case, output one integer on one separate line, representing the minimum amount of time needed to complete the trip. If there is no way for Green to reach the destination, output -1 instead.
 

Sample Input
  
  
4 6 1 2 10 T...TT TTT### TT.@#T ..###@ 0 1 3 0 4 6 1 2 2 T...TT TTT### TT.@#T ..###@ 0 1 3 0 2 2 5 1 3 T@ @. 0 0 1 1
 

Sample Output
  
  
Case 1: 14 Case 2: 8 Case 3: -1
 
一看这一题第一感觉就是BFS,之前也练了几个BFS的题,写的挺顺畅。但是后来输出结果一直都不对,后来检查也没怎么检查。
今天回过头来看,BFS的确可以,跟我想的差不多,缺少一点细节
第一:什么时候跳出 while(s.size()) ,bfs是只要到达目标就可以,最短路径嘛。但是这一题不同,他要绕路,才能保证到目标最小,所以得一直遍历
第二:关于石头不遍历,就设一个大数,只要不等于它才往下走,
第三:最关键的,耗费的时间 ,走到那一点与那一点原来的取最小的就是该点到开始的最小,这一部分还有点生疏



还有这题好像有点坑,输入要求好像有什么空行,没加什么就AC了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
typedef pair<int,int> point;
const int INF=100000;

int map[30][30];

int num[30][30];
int r,c;
int sr,sc,tr,tc;
int step[4][2]={{-1,0},{1,0},{0,1},{0,-1}};
int total;
void bfs(int sx,int sy)
{
    point  p;
    p.first=sx,
    p.second=sy;
    num[sx][sy]=0;

    queue<point> s;
    s.push(p);
    //cout<<p.first<<" "<<p.second<<endl;
    while(s.size())
    {

        p=s.front();
        s.pop();
        //cout<<p.first<<" "<<p.second<<endl;
       // cout<<tr<<" "<<tc<<endl;
        if(p.first==tr&&p.second==tc)
        {
            total=num[tr][tc];
           // cout<<"wrong"<<endl;

        }

        for(int i=0;i<4;i++)
        {
         int fx=p.first+step[i][0];
         int fy=p.second+step[i][1];
         if(fx>=0&&fx<r&&fy>=0&&fy<c)
         {
             // cout<<num[fx][fy]<<endl;
              //cout<<num[p.first][p.second]+map[fx][fy]<<endl;
             if((num[fx][fy]>num[p.first][p.second]+map[fx][fy])&&map[fx][fy]!=INF)
              {
                  num[fx][fy]=num[p.first][p.second]+map[fx][fy];

                  point p1;
                  p1.first=fx;
                  p1.second=fy;

                 s.push(p1);
              }

         }

           }

    }
}

int main()
{
    int count=0;
    while(cin>>r>>c)
    {
        char ch;
        int vp,vs,vt;

        total=0;
        cin>>vp>>vs>>vt;

        for(int i=0;i<r;i++)
         for(int j=0;j<c;j++)
          {
           cin>>ch;
          if(ch=='T')
          map[i][j]=vt;
          if(ch=='.')
          map[i][j]=vs;
          if(ch=='#')
          map[i][j]=vp;
          if(ch=='@')
          map[i][j]=INF;
          num[i][j]=INF;
          }
         /*for(int i=0;i<r;i++)
           {
            for(int j=0;j<c;j++)
            cout<<map[i][j]<<" ";

             cout<<endl;
           }*/
          cin>>sr>>sc>>tr>>tc;

          //memset(num,INF,sizeof(num));
         /*for(int i=0;i<r;i++)
           {
            for(int j=0;j<c;j++)
            cout<<num[i][j]<<" ";

             cout<<endl;
           }*/

          bfs(sr,sc);

       count++;
       cout<<"Case "<<count<<": ";
       if(num[tr][tc]==INF)
        cout<<"-1"<<endl;
       else
        cout<<total<<endl;

    }


    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值