C-Cow Sorting (置换群, 数学)

Farmer John's N (1 ≤ N ≤ 10,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage FJ's milking equipment, FJ would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (not necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes FJ a total of X+Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help FJ calculate the minimal time required to reorder the cows.

Input
Line 1: A single integer: N.
Lines 2.. N+1: Each line contains a single integer: line i+1 describes the grumpiness of cow i.
Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
Sample Input
3
2
3
1
Sample Output
7
Hint
2 3 1 : Initial order.
2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4).
1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).
 
题意:有一群牛, 没头牛都有一个独一无二的暴躁度, 农夫想把暴脾气的牛排在后面, 他会将两头牛交换位置, 代价是两头牛的暴躁度之和;将所有的牛排好序, 最小的代价是多少?
 
思路:因为交换自然想到置换群,我们可以用循环里最小的数做媒介将较大的数换到相应的位置, 易得排好一个循环的代价为 :ans1 = sum+(cnt-2)*min;(cnt为循环长度,sum为循环的和,min为该循环的最小值)但这样做并一定不是最小的, 比如序列 : 17896; 两个循环(1)(7896), 用上面的公式得到 ans1 = 42, 但如果我们把1和6交换,用1作为媒介,代价为:
ans2 = sum+(cnt+1)*MIN+min(MIN为全局最小数), 通过比较ans1, ans2得到最小值;
 
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>


#define maxn 100010

using namespace std;

int hay[maxn], shay[maxn], vis[maxn], pos[maxn];
int mi = 105, ans = 0, MI = 105;
int n;
int main()
{
    memset(vis, 0, sizeof(vis));
    ios::sync_with_stdio(false);

    cin >> n;
    for(int i = 1; i <= n; i++)
    {
        cin >> hay[i];
        shay[i] = hay[i];
        mi = min(mi, hay[i]);
    }
    sort(hay+1, hay+n+1);
    for(int i = 1; i <= n ; i++)
    {
        pos[hay[i]] = i;
    }
    for(int i = 1 ;i <= n; i++)
    {
        if(vis[i] == 0)
        {
            int tmp = i;
            int cnt = 0;
            int sum = 0;
            MI = shay[tmp];
            while(vis[tmp] == 0)
            {
                vis[tmp] = 1;
                cnt++;
                sum += shay[tmp];
                tmp = pos[shay[tmp]];
                MI = min(MI, shay[tmp]);
            }
            ans += (sum + min((cnt-2)*MI, MI+(cnt+1)*mi));
        }
    }
    cout << ans  << endl;
    return 0;
}
这里没有代码。。。

参考链接 :http://www.cnblogs.com/kuangbin/archive/2012/09/03/2669013.html

 
 
 

转载于:https://www.cnblogs.com/mrh-acmer/p/9469506.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值