POJ 2654 <Rock-Paper-Scissors Tournament >

Description

Rock-Paper-Scissors is game for two players, A and B, who each choose, independently of the other, one of rock, paper, or scissors. A player chosing paper wins over a player chosing rock; a player chosing scissors wins over a player chosing paper; a player chosing rock wins over a player chosing scissors. A player chosing the same thing as the other player neither wins nor loses.
A tournament has been organized in which each of n players plays k rock-scissors-paper games with each of the other players - k*n*(n-1)/2 games in total. Your job is to compute the win average for each player, defined as w / (w + l) where w is the number of games won, and l is the number of games lost, by the player.

Input

Input consists of several test cases. The first line of input for each case contains 1 <= n <= 100 1 <= k <= 100 as defined above. For each game, a line follows containing p1, m1, p2, m2. 1 <= p1 <= n and 1 <= p2 <= n are distinct integers identifying two players; m1 and m2 are their respective moves ("rock", "scissors", or "paper"). A line containing 0 follows the last test case.

Output

Output one line each for player 1, player 2, and so on, through player n, giving the player's win average rounded to three decimal places. If the win average is undefined, output "-". Output an empty line between cases.

Sample Input

2 4
1 rock 2 paper
1 scissors 2 paper
1 rock 2 rock
2 rock 1 scissors
2 1
1 rock 2 paper
0

Sample Output

0.333
0.667

0.000
1.000

Hint

Huge input,scanf is recommended.
简单的水题,算概率。理解题意就行
AC代码:
#include<iostream>
#include<stdio.h>
#include<string.h>

using namespace std;


int main()
{
    char m1[10], m2[10];
    int owin[210], olose[210], p1, p2, i, n, m, k = 0;
    while (~scanf("%d", &n) && n)
    {
        scanf("%d", &m);
        if (k)printf("\n");
        memset(owin, 0, sizeof(owin));
        memset(olose, 0, sizeof(olose));
        for (i = 0;i<m*n*(n - 1) / 2;++i)
        {
            scanf("%d%s%d%s", &p1, m1, &p2, m2);
            if ((!strcmp(m1, "rock") && !strcmp(m2, "scissors")) || (!strcmp(m1, "scissors") && !strcmp(m2, "paper")) || (!strcmp(m1, "paper") && !strcmp(m2, "rock")))
                owin[p1]++, olose[p2]++;
            if ((!strcmp(m1, "rock") && !strcmp(m2, "paper")) || (!strcmp(m1, "paper") && !strcmp(m2, "scissors")) || (!strcmp(m1, "scissors") && !strcmp(m2, "rock")))
                owin[p2]++, olose[p1]++;
        }
        for (i = 1;i <= n;++i)
            if (owin[i] + olose[i])
                printf("%.3lf\n", (double)owin[i] / (owin[i] + olose[i]));
            else
                printf("-\n");
        k++;
    }
}

 

转载于:https://www.cnblogs.com/914295860-jry/p/5822298.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值