POJ 3692:Kindergarten(最大的使命)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4920 Accepted: 2399

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
GB (1 ≤ GB ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

题意:幼儿园里男孩纸跟男孩纸认识,女孩纸跟女孩纸认识,男孩纸跟女孩纸也部分认识。

须要求出最大的,能使里面全部男孩纸女孩纸都认识的集合(最大团)

1.独立集:随意两点都不相连的顶点的集合 

2.定理:最大独立集=顶点数-最大匹配边

3.全然子图:随意两点都相连的顶点的集合(最大全然子图即最大团)  

4.定理:最大团=原图补图的最大独立集=顶点数-最大匹配数

注意,要反向建图(把认识的变成不认识的。不认识的成为认识的,这样才干求补图


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 1000 + 5;
int k, m, n;
int link[M];
bool MAP[M][M];
bool cover[M];
int ans;
int cas=0;

void init()
{
    int x, y;
    memset(MAP, true, sizeof(MAP));
    for(int i=1; i<=k; i++)
    {
        scanf("%d%d", &x, &y);
        MAP[x][y]=false;
    }
}

bool dfs(int x)
{
    for(int y=1; y<=m; y++)
    {
        if(MAP[x][y] && !cover[y])
        {
            cover[y]=true;
            if(!link[y] || dfs(link[y]))
            {
                link[y]=x;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while(scanf("%d%d%d", &n, &m, &k) && n && m && k)
    {
        cas++;
        ans=0;
        init();
        memset(link, false, sizeof(link));
        for(int i=1; i<=n; i++)
        {
            memset(cover, 0, sizeof(cover));
            if( dfs(i) )
                ans++;
        }
        printf("Case %d: %d\n", cas,(n+m)-ans);
    }

    return 0;
}




版权声明:本文博客原创文章。博客,未经同意,不得转载。

转载于:https://www.cnblogs.com/bhlsheji/p/4750645.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值