计算机学院大学生程序设计竞赛(2015’12)Happy Value

Happy Value

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1337    Accepted Submission(s): 392


Problem Description
In an apartment, there are N residents. The Internet Service Provider (ISP) wants to connect these residents with N – 1 cables. 
However, the friendships of the residents are different. There is a “Happy Value” indicating the degrees of a pair of residents. The higher “Happy Value” is, the friendlier a pair of residents is. So the ISP wants to choose a connecting plan to make the highest sum of “Happy Values”.
 

Input
There are multiple test cases. Please process to end of file.
For each case, the first line contains only one integer N (2<=N<=100), indicating the number of the residents.
Then N lines follow. Each line contains N integers. Each integer H ij(0<=H ij<=10000) in i th row and j th column indicates that i th resident have a “Happy Value” H ijwith j th resident. And H ij(i!=j) is equal to H ji. H ij(i=j) is always 0.
 

Output
For each case, please output the answer in one line.
 

Sample Input
 
  
2 0 1 1 0 3 0 1 5 1 0 3 5 3 0
 

Sample Output
 
  
1 8
 

总是望着曾经的空间发呆,那些说好不分开的朋友不在了,转身,陌路。 熟悉的,安静了, 安静的,离开了, 离开的,陌生了, 陌生的,消失了, 消失的,陌路了。 快哭了

#include <stdio.h>
#include <string.h>
#define MaxInt 9999999
#define N 110
int map[N][N],low[N],visited[N],n;
int prim()
{
    int i,j,pos=1,min,result=0;
    memset(visited,0,sizeof(visited));
    visited[1]=1;
    for(i=2; i<=n; i++)
       low[i]=map[pos][i];
    for(i=1; i<n; i++)
    {
        min=MaxInt;
        for(j=1; j<=n; j++)
            if(visited[j]==0&&min>low[j])
            {
                min=low[j];
                pos=j;
            }
        result+=min;
        visited[pos]=1;
        for(j=1; j<=n; j++)
            if(visited[j]==0&&low[j]>map[pos][j])
                low[j]=map[pos][j];
    }
    return result;
}
int main()
{
    int i,v,j,ans;
    while(scanf("%d",&n)!=EOF)
    {
        memset(map,MaxInt,sizeof(map));
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                scanf("%d",&v);
                map[i][j]=-v;
            }
        ans=-1*prim();
        printf("%d\n",ans);
    }
    return 0;
}

@执念  "@☆但求“❤”安★ 下次我们做的一定会更好。。。。吐舌头

为什么这次的题目是英文的。。。。QAQ... 哭

转载于:https://www.cnblogs.com/im0qianqian/p/5989698.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值